Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

#825234
After install a new server and follow the steps in https://wiki.processmaker.com/3.3/Proce ... stallation
I get the error The requested URL /sys/en/neoclassic/login/login was not found on this server.
Previously I get the error saying that dont find the template dir (I make a copy in the target location)
Attachments
(599 Bytes) Downloaded 24 times
#825236
If you haven't enabled the 8080 port in one of your other files (like /etc/apache2/apache2.conf), then you need to add:
Listen 8080

You have different two different paths, so one of these is wrong:
DocumentRoot /opt/to/processmaker/workflow/public_html
<Directory /opt/processmaker/workflow/public_html>

(I suspect that the first one is wrong.)

Try this:
Code: Select all
Listen 8080
<VirtualHost *:8080>
    ServerName 172.16.2.35

    DocumentRoot /opt/processmaker/workflow/public_html
    DirectoryIndex index.html index.php

    <Directory /opt/processmaker/workflow/public_html>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
        Require all granted

        #ExpiresActive On

        <IfModule mod_rewrite.c>
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^.*/(.*)$ app.php [QSA,L,NC]
        </IfModule>
    </Directory>
</VirtualHost>
Remember that you need to restart Apache or reboot after every change.

You would have caught this error if you had checked the Apache service with this command:
systemctl status apache2

You should see something like this:
Code: Select all
# systemctl status apache2
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-05-31 18:59:13 -04; 1 months 1 days ago
  Process: 23629 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS)
  Process: 6533 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=0/SUCCESS)
  Process: 23636 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
 Main PID: 23640 (apache2)
    Tasks: 11 (limit: 4915)
   CGroup: /system.slice/apache2.service
           ├─ 6558 /usr/sbin/apache2 -k start
           ├─ 6861 /usr/sbin/apache2 -k start
           ├─ 7505 /usr/sbin/apache2 -k start
           ├─ 7509 /usr/sbin/apache2 -k start
           ├─ 9386 /usr/sbin/apache2 -k start
           ├─10639 /usr/sbin/apache2 -k start
           ├─18265 /usr/sbin/apache2 -k start
           ├─18270 /usr/sbin/apache2 -k start
           ├─18319 /usr/sbin/apache2 -k start
           ├─18601 /usr/sbin/apache2 -k start
           └─23640 /usr/sbin/apache2 -k start

Jun 26 00:10:16 debian systemd[1]: Reloading The Apache HTTP Server.
Jun 26 00:10:16 debian systemd[1]: Reloaded The Apache HTTP Server.
Jun 27 00:09:22 debian systemd[1]: Reloading The Apache HTTP Server.
Jun 27 00:09:22 debian systemd[1]: Reloaded The Apache HTTP Server.
Jun 28 16:49:03 debian systemd[1]: Reloading The Apache HTTP Server.
Jun 28 16:49:03 debian systemd[1]: Reloaded The Apache HTTP Server.
Jul 01 21:35:12 debian systemd[1]: Reloading The Apache HTTP Server.
Jul 01 21:35:12 debian systemd[1]: Reloaded The Apache HTTP Server.
Jul 02 00:08:30 debian systemd[1]: Reloading The Apache HTTP Server.
Jul 02 00:08:30 debian systemd[1]: Reloaded The Apache HTTP Server.
#825277
amosbatto wrote: Tue Jul 02, 2019 7:09 pm If you haven't enabled the 8080 port in one of your other files (like /etc/apache2/apache2.conf), then you need to add:
Listen 8080
transfers Dieppe
You have different two different paths, so one of these is wrong:
DocumentRoot /opt/to/processmaker/workflow/public_html
<Directory /opt/processmaker/workflow/public_html>

(I suspect that the first one is wrong.)

Try this:
Code: Select all
Listen 8080
<VirtualHost *:8080>
    ServerName 172.16.2.35

    DocumentRoot /opt/processmaker/workflow/public_html
    DirectoryIndex index.html index.php

    <Directory /opt/processmaker/workflow/public_html>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
        Require all granted

        #ExpiresActive On

        <IfModule mod_rewrite.c>
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^.*/(.*)$ app.php [QSA,L,NC]
        </IfModule>
    </Directory>
</VirtualHost>
Remember that you need to restart Apache or reboot after every change.

You would have caught this error if you had checked the Apache service with this command:
systemctl status apache2

You should see something like this:
Code: Select all
# systemctl status apache2
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-05-31 18:59:13 -04; 1 months 1 days ago
  Process: 23629 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS)
  Process: 6533 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=0/SUCCESS)
  Process: 23636 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
 Main PID: 23640 (apache2)
    Tasks: 11 (limit: 4915)
   CGroup: /system.slice/apache2.service
           ├─ 6558 /usr/sbin/apache2 -k start
           ├─ 6861 /usr/sbin/apache2 -k start
           ├─ 7505 /usr/sbin/apache2 -k start
           ├─ 7509 /usr/sbin/apache2 -k start
           ├─ 9386 /usr/sbin/apache2 -k start
           ├─10639 /usr/sbin/apache2 -k start
           ├─18265 /usr/sbin/apache2 -k start
           ├─18270 /usr/sbin/apache2 -k start
           ├─18319 /usr/sbin/apache2 -k start
           ├─18601 /usr/sbin/apache2 -k start
           └─23640 /usr/sbin/apache2 -k start

Jun 26 00:10:16 debian systemd[1]: Reloading The Apache HTTP Server.
Jun 26 00:10:16 debian systemd[1]: Reloaded The Apache HTTP Server.
Jun 27 00:09:22 debian systemd[1]: Reloading The Apache HTTP Server.
Jun 27 00:09:22 debian systemd[1]: Reloaded The Apache HTTP Server.
Jun 28 16:49:03 debian systemd[1]: Reloading The Apache HTTP Server.
Jun 28 16:49:03 debian systemd[1]: Reloaded The Apache HTTP Server.
Jul 01 21:35:12 debian systemd[1]: Reloading The Apache HTTP Server.
Jul 01 21:35:12 debian systemd[1]: Reloaded The Apache HTTP Server.
Jul 02 00:08:30 debian systemd[1]: Reloading The Apache HTTP Server.
Jul 02 00:08:30 debian systemd[1]: Reloaded The Apache HTTP Server.
hi, thank you very much, i'm trying and it works
Amosbatto, PMUsers.com is down.

It would be nice if ProcessMaker can let us know w[…]

Hi, What is your server config? Is your server Wi[…]

Hi, It's not possible, because processmaker set s[…]

Filtering Grids For Parallel Tasks

Hi, You must create a grid for example @=tempGrid[…]