Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderator: amosbatto

By NAlvarado
#816012
My main dynaform has 2 before triggers that generates an approval list (drop down list with an array variable) and grabs the logged user as the requester. These two values are then loaded on the dynaform (Originator) . I setup the WF to be a Web Entry as the uses would like to access from the intranet. I tried setting it so that the Originator dynaform opens and also tried with Multiple (calling the 2 triggers and then the dynaform), however neither seems to work. When accessing the workflow via the generated link, the form opens, but the approver list is not generated (array is blank) and the requester (@@USER_LOGGED) does not appear on my form. There's no issue when i create a new case from processmaker. What am I doing wrong or missing? I do have the web entry set to require the user to login.
By amosbatto
#816027
What version of ProcessMaker? Web Entry was totally rewritten in version 3.2.2.

I haven't checked the code in 3.2.2 and later to see how it works, but in 3.2.1 and earlier, there are no triggers with Web Entry forms, so your triggers probably aren't firing. The only workaround is to add JavaScript to your form to call the REST endpoint POST cases/{app_uid}/execute-trigger/{tri_uid}

See: https://wiki.processmaker.com/3.2/JavaS ... ing_jQuery
By amosbatto
#816034
If you want to execute the trigger using JavaScript, see this code example:
viewtopic.php?t=713486#p795277

The tricky part is the fact that the PUT /cases/{app_uid}/execute-trigger/{tri_ui} endpoint requires that the case already exists, but in web entry there is not yet a case, since it will be created when the web entry form is submitted. What you have to do is create another case in the process which you will never close, which is just used for executing triggers.

PS: I am planning to add an endpoint to my extraRest plugin so it is not necessary to have a case when executing a trigger. If you are interested, I will post here when it is ready to be used.
By acamador
#816289
Buen dia estimados.
Yo tengo el mismo problema tengo un web entry y unos campos de busqueda dentro del formulario, y conforme a la busqueda necesito llenar una grid. Como soluciono ejecutar un trrigger durante finalizo la busqueda en el web entry.

Visualice que usted coloco lo siguiente:

PD: Estoy planeando agregar un punto final a mi complemento extraRest, por lo que no es necesario tener un caso al ejecutar un desencadenador. Si está interesado, publicaré aquí cuando esté listo para ser utilizado.

【Q/微信729926040】如以删除请点网页快照,专业办理德国/法国/英国/加拿大各大学高端精仿文[…]

【Q/微信729926040】如以删除请点网页快照,专业办理德国/法国/英国/加拿大各大学高端精仿文[…]

【Q/微信729926040】如以删除请点网页快照,专业办理德国/法国/英国/加拿大各大学高端精仿文[…]

【Q/微信729926040】如以删除请点网页快照,专业办理德国/法国/英国/加拿大各大学高端精仿文[…]