Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderator: amosbatto

#814753
See this error that is happening when I upload a file in dynaform or input docs and then I try to download.
Trying to download gives this error:
Screenshot_3.png
Screenshot_3.png (48.92 KiB) Viewed 2720 times
PS: this only happens in large files above 50/60 Mb ... I've already tried changing PHP.INI ...
Last edited by marcosfpa on Tue Jun 19, 2018 9:01 am, edited 1 time in total.
#814781
Check if the file was saved as a record to the database and as a file to the PM server.
Do a query like this in your workspace database in MySQL:
SELECT * FROM APP_DOCUMENT WHERE APP_DOC_FILENAME = '20180401_200127.pm4';

Then, take use the information returned by that query to check if the file was saved to the PM server:
{/opt}/processmaker/shared/sites/{workspace}/files/{APP_UID in 4 directories}/{APP_DOC_UID}_{DOC_VERSION}.{EXT}

If the file exists on the server, then you should verify that your login session has expired and your logged-in user has rights to access the file. If in doubt, grant the user Process Permissions to the Input Document.
#814812
The env.ini file allows you to redefine some of the settings like memory_limit. If you are using a Bitnami installation, then you need to also change the apps/processmaker/conf/httpd-app.conf file, because it overwrites the settings in the php.ini file.

Put this code in a trigger and run a case a verify that it is the same as in your php.ini file:
Code: Select all
print "<pre>" .
   "memory_limit=". ini_get ("memory_limit") ."\n".
   "max_file_uploads=". ini_get ("max_file_uploads") ."\n". 
   "post_max_size=". ini_get ("post_max_size") ."\n".
   "upload_max_filesize=". ini_get ("upload_max_filesize") ."\n".
   "max_execution_time=". ini_get ("max_execution_time") ;
die;
#822304
heemalkumar wrote:I am getting same error
Please advise how was this fixed. Where is the Apache2 file located?
It would help if you explained what system you are using.

There is no apache2.conf file in ProcessMaker. I assume that he is talking about is the /etc/apache2/apache2.conf file found in Debian and Ubuntu, where he probably added a line like this:
php_value upload_max_filesize 100M

This is not the recommended way to do it, but it works.

If you have a Bitnami installation of ProcessMaker, then first it reads the file:
C:\Bitnami\processmaker-3.3.0-1\php\php.ini
Then a few PHP settings are overwritten in the file:
C:\Bitnami\processmaker-3.3.0-1\apps\processmaker\conf\httpd-app.conf
These are the settings which are overwritten by httpd-app.conf:
Code: Select all
          php_value short_open_tag On
            php_value memory_limit 512M
            php_value upload_max_filesize 20M
            php_value max_input_vars 8000
If you have a manual install, then all the settings are found in php.ini, but you might have multiple installations of PHP, so verify which version you are using by going to Admin > Settings > PHP Information in ProcessMaker.

i sure it is very interesting and entertaint for y[…]

ok, Where should I set the TRIGGER in this simple[…]

No clue. I've never tried using that. You can cha[…]

When you are inside the ProcessMaker interface and[…]