Un foro de discusión para nuestra comunidad de hispano hablante

Moderator: amosbatto

By johahel18
#814685
Amigos, estoy realizando el upgrade de mi processmaker 3.1.2 a la version 3.1.3 y cuando utilizo la opcion ./processmaker me sale el siguiente error

PHP Fatal error: Cannot redeclare class pakeGetopt in /opt/processmaker/gulliver/thirdparty/pake/pakeGetopt.class.php on line 26

alguien podria ayudarme a corregir este problema

gracias
By amosbatto
#814687
¿Qué sistema operativo tienes?

Primero, debes chequear la versión de PHP para verificar que estas usando PHP 5.5 o 5.6:
Code: Select all
php -v 
Es posible que tienes varias instalaciones de PHP en tu servidor y tienes que especificar la ruta completa para executar la version correcta. También tienes que cambiar al directorio antes de executar el comando de processmaker

Por ejemplo, en mi servidor de Linux, yo hago:
Code: Select all
su  
cd /opt/processmaker
/usr/bin/php5.6 processmaker upgrade  
By johahel18
#814695
tengo instalado centos 7, hice una instalacion de la misma version con los mismos pasos en manera local y el comando ./processmaker se ejecuto de manera normal pero en el otro equipo no puedo ejecutarlo


[[email protected] processmaker]# php -v
PHP 5.6.35 (cli) (built: Mar 30 2018 08:28:49)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
[[email protected] processmaker]#
By johahel18
#814696
encontre la solucion, tenia instalado los modulos php56w-opcache php56w-fpm los removi y volvi a probar, y se ejecuto con normalidad

Dear ALl, I have a dynaform with the below scenari[…]

Hello Andrea, Basically, I have 2 boolean variabl[…]

After adding the code here are the error messages.[…]

Hi, You can try to follow the instructions in th[…]