Moderators: ArturoRobles, ArturoRobles

Hi everyone, we are really excited to give all of you another sneak peak at what will be the final version of ProcessMaker Community 3.0.

This is the first of two release candidates we will be launching. This comes with great new features and tons of bug fixes.

Remember that this is still a BETA release. Do not use this BETA version in a production environment.

New features:

- Possibility to enable or disable Grid Lines.
- Shape toolbox position is now horizontally.
- Possibility to define the Data object type as “empty”
- Link and file fields added inside Grids.

Bug Fixes:

- Change sample Apache VirtualHost definition file for ProcessMaker
- Error when running a case in a process that has a subprocess within it without the definition of variables.
- If using Windows, pop up’s do not have an X button to close it.
- The context menu remains static if using the assignment rules interface and task properties.
- Change some text in the Trigger Wizard.
- Upload icon cannot be seen completely.
- Edit Inputdoc – Confirm action does not validate any changes made in Input Documents.
- When editing a trigger, the cancel button does not have a confirmation dialog.
- Validation error while creating the PMFNewCase function.
- There is no validation when importing a responsive form with an invalid extension.
- The following syntaxis error appears when using the PMFGetCasesNotes() function, unexpected ‘,’, expecting ‘(‘.
- “Date” and “DateTime” have the same properties in the Dynaform designer.
- If using Internet Explorer, triggers cannot be created.
- There isn’t a ProcessMap window information.
- Error in the Data Type and Data Object.
- The option in the Formula properties does not have any action in grids.
- Extra bullets in the message when removing a DynaForm from the list of Steps inside Processes Supervisor.
- It is not possible to see all the text in the user’s field in the Start Message event.
- Process configuration as public or private is not available.
- Error saving a form on view mode.

Known issues:

- BPMN Designer Import standardization of elements size.
- WebEntry refactor.
- When the PMFGetCasesNotes() function is being executed in a trigger, it displays a syntax error: unexpected ‘,’, expecting ‘(‘.
- Date validation grid.
- Time in Self Service Assignment Rule accepts letters.
- Read the complete Release Notes for a detailed description of new features, known issues and bugs-fixes.


* The directory where ProcessMaker is installed should have write permissions.

* Remember that this is a BETA release. Do not use this BETA version in a production environment.


* English (Default Core)

Beta Availability

ProcessMaker 3.0 Beta version is available for Linux and Windows platforms. Download them from this site.


* For a detailed description of ProcessMaker 3.0 and its new features please see our latest documentation.

* To report any issues in ProcessMaker 3.0 (RC1) please go to this page, select ProcessMaker [community] “Project” and select “ProcessMaker v3.0 RC1″ in Product version.

How to contribute?

* We need your help to make ProcessMaker 3.0 the best release, so please take some time to download and try out the beta, your feedback is very important to us!.

* if you are willing to help us translating this version into your native language just tell us by sending an email to [email protected].

Don’t forget that any contribution will be mentioned in our wiki, social media and forum…so help spread the word!

Enjoy it!
Hi liliana

I installed the PM v.3.0 (RC1) on a test CENTOS 7.0 server. I followed all the instructions to the letter I think.

I could access the servers from my workstation and went through a normal installation.

However, after I login as an administrator and clicking on the DESIGNER tab I can only see the classic version of the process designer. The BPMN version is not available. I tried reinstalling but the results are the same.

I installed the Windows version of v.3.0 (RC1) on my local machine and it works perfectly.

Can anyone help?
I've just started to use RC1, and I'm getting the following error when trying to preview a dropdown populated from user data in the default db:

No connection params set for 555019319550b0fcfcf7209063422441

I'm creating a BPMN project. I've defined a local db connection to the appropriate workflow database and tested it.
I've created a string variable, found the db connection in the dropdown for "Database Connection", and used the following Sql:


I've created a new form in Dynaforms, and dragged the created variable into the form. Selected "dropdown". The form element was auto-populated with SQL info from the variable, including the "DB Connection" which was "555019319550b0fcfcf7209063422441" (the same ID as the error number above).

When I preview the form I get the above error. Here are the remainder of the error lines:

At Propel::getConnection()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 115
At pmDynaform->jsonr()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 78
At pmDynaform->jsonr()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 78
At pmDynaform->jsonr()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 78
At pmDynaform->jsonr()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 78
At pmDynaform->jsonr()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 78
At pmDynaform->jsonr()
in /installdir/workflow/engine/classes/class.pmDynaform.php line 340
At pmDynaform->printPmDynaform()
in /installdir/workflow/engine/methods/cases/pmDynaform.php line 6
At require_once() in /installdir/workflow/public_html/sysGeneric.php line 977
At include() in /installdir/workflow/public_html/app.php line 52

I'm baffled. Any help would be appreciated. I've been through all of the relevant documentation and can't figure out if it is a bug or I'm doing something wrong.
Estimada, llevo unos días probando la RC1 y tengo la siguiente consulta:
¿Es posible en esta versión tener un campo de texto dependiente de otro campo de texto?
Pregunto esto ya que en el editor de formularios BPMN al elegir un campo dependiente solo sale la opción de elegir un campo del formulario tipo dropdown, tomando en cuenta que en el formulario tengo posibles campos como texto, radiogroup, text área y etc.

Segundo, he notado que las consultas SQL para campos de texto ya no obedecen a la estructura [SELECT columna1 FROM tabla1 WHERE columna =’algo’], lanza un error en la preview y en la ejecución del formulario (consulta probada con éxito en el mismo rc1 en un proceso con formulario de la versión 2.X), mientras que si la consulta se cambia a una estructura [SELECT columna1, columna2 FROM tabla1 WHERE columna =’algo’], funciona correctamente, implicando que todas las consultas ¿SQL deben venir con una respuesta de [ID, contenido de la consulta]?

saluda atte luis
Hola NLj015,
Recientemente estuve haciendo pruebas con los campos dependientes y en mi caso si te permite usar campos de tipo texto el problema es que el campo no se esta populando (Revisare esto con nuestro equipo de desarrollo).

Por otro lado si es necesario que definas el UID de tu campo para las consultas.


I have also confirmed this database connection bug - was it ever actually reported in the bug tracker? Or resolved?

I can successfully connect and perform an SQL query against the 'workflow' database native to ProccessMaker, but if I try a connection to any other database outside of processmaker, it induces the error. I have utlized the standalone installer - so I haven't created a database on the localhost to test to see if I will connect to that). I have added 2 connections, and tested them (they say that they are successful).

I started going back to previous documentation and looking at the 'trigger' way to do it - but that doesn't work either as far as I can tell (not in preview - or otherwise). This is a pretty critical feature - to utilize external databases for field population.

I tried to login to the bug reporting system, but it replied that my login was bad.


disable value in dropdown

Check box is more helpful rather than drop down op[…]

Timeout Not Sending Email

I would like to thank you for the efforts you have[…]

use 'insert into' in a trigger

Is your syntax correct? Shouldn't you be using s[…]

issue with processmaker 3.2

You mean the code in the trigger below? That is t[…]