Ask questions about installing and configuring ProcessMaker 3
User avatar
By RJBrown
#830290
Good Morning,

I've been task with migrating ProcessMaker from an older application server to a server with Server 2022.

My current production server is MS server 2012 R2, ProcessMaker 3.5.4 Community, PHP 7.1.9, MySql 5.6.51.

I've created a test environment with MS server 2022, ProcessMaker 3.5.4 Community, PHP 7.1.9, MySql 5.7.40.

The current production ProcessMaker has 4 (projects) with 3 of the 4 exporting from production and importing into my test environment just fine. But the 4th Project has consistently errored on import.

I've attached the error that I get when I try and Import.

Any help with this would be greatly appreciated. Once I get over this hurdle, I will need to bring the data over from MySql and then Upgrade ProcessMaker on my test system.

Thank you,
Rob
Attachments
PMError.PNG
PMError.PNG (24.63 KiB) Viewed 39866 times
By silviuA
#830299
Is it possible that the file that you are trying to import is to big? If this is the case, try to increase memory_limit in php.ini - like for example:
Code: Select all
memory_limit = 512M
Also here https://wiki.processmaker.com/3.0/Changing_the_ProcessMaker_Configuration#Increasing_the_maximum_memory_per_session it says to also modify the sysGeneric.php on line 7 to reflect the change - something like:
Code: Select all
 ini_set('memory_limit', '512M');
Cheers!
By BaileyDaugherty
#830306
Do you think the file you're trying to import might be too big? To fix this, try increasing memory limit in php.ini to a larger value, such as: https://basketball-stars.co/
User avatar
By RJBrown
#830311
silviuA wrote: Thu Nov 17, 2022 10:18 am Is it possible that the file that you are trying to import is to big? If this is the case, try to increase memory_limit in php.ini - like for example:
Code: Select all
memory_limit = 512M
Also here https://wiki.processmaker.com/3.0/Changing_the_ProcessMaker_Configuration#Increasing_the_maximum_memory_per_session it says to also modify the sysGeneric.php on line 7 to reflect the change - something like:
Code: Select all
 ini_set('memory_limit', '512M');
Cheers!
Thank you for your reply.

I had already set the file size to 512 in the php.ini.

The files itself is just under 5mb.
User avatar
By stefant85
#830326
If you ever wanted to switch from PC to Mac or vice versa, these settings will make the switch process much easier. In fact, once these changes are made, it'll be as if nothing changed at all.
User avatar
By RJBrown
#830400
stefant85 wrote: Tue Dec 13, 2022 1:53 am If you ever wanted to switch from PC to Mac or vice versa, these settings will make the switch process much easier. In fact, once these changes are made, it'll be as if nothing changed at all.
I see that reporting posts serves no purpose. :-D I reported this back in the middle of December and its still here.

BTW I fixed my issue.
Error While Importing

If you ever wanted to switch from PC to Mac or v[…]

To do this only in MySQL is definitely not recom[…]

Is it possible to open a dynaform using a link rat[…]

Whne run php.exe processmaker help , I get error […]