Ask questions about your install or get help installing and configuring ProcessMaker 2
Okay, so I download community edition, install it on Win7 x64 and get it running. Great. Time to connect it to SQL Server so I can do something with it.

I soon find "SQL Server compatible" means "You still have to use MySQL for ProcessMaker, but it'll link to MSSQL if you want to do stuff during a process".

Oookay, no biggie.

I look up ... SQL_Server and start to follow the instructions.
If Microsoft SQL Server is installed on the same machine as ProcessMaker, then ProcessMaker should automatically detect it and it should be listed as an available option under Database Connections.
I don't want to install SQL Server on the same server as PM. I have many servers I need to link to.
Otherwise, install the FreeTDS. Follow the steps below in order to isntall FreeTDS under a Windows installation:

1.FreeTDS requires the .NET Framework v1.1 to be installed.
Hmm. Windows comes with later versions of the framework, that are supposed to backward compatible. Does this mean I still need to download it? Guess I'll have to, to be on the safe side. I download, try to install and it won't because it'll screw up IIS. Okay, it should still run though. Step 2 is fine, download a file and put it in /ext. Gotcha.
3.Then edit the php.ini file, that is generally located at C:\Users\community\AppData\Roaming\ProcessMaker-3_0_0_4_community\php, to enable the mssql extension:

So I open the ini and look for this line. It's not there. There are zillions of other lines commented out, so you'd think something as major as SQL Server would be there, but no.
There's a line that mentions msql.dll though. Is this the same thing? I put in both to be on the safe side.
Then restart the Apache server to use the new PHP configuration, by going to the command line (located at Start > All Programs > Accessories > Command Prompt) and issuing the command:

httpd -k restart
"httpd is not recognized as an internal or external command yadda yadda path wrong".

It's not in /php/. I search my whole PC and find it in \apache2\bin\ even though the docs are talking about still being in \php\ (or assuming apache2\bin is in the path, which it isn't).

So I go to Apache2\bin and do the httpd -k restart and get
The system cannot find the file specified. : AH00436: No installed service named "Apache2.4".
Lovely. But that's not the only way to start the server, right? I find the catchy-named Bitnami ProcessMaker Open Source Edition Stack, go to Manage Servers, restart the Apache Web Server, go into PM, lose a lot of time poking around in settings, eventually find you have to create a process to be able to set up a connection, and try. SQL is not in the dropdown.
If for some reason the SQL Server option does not appear in the list of Database Connections, restart the OS to apply changes.
OK. STILL not in the dropdown.
To verify that PHP is now using the mssql extension, create a file named info.php with a bare text editor containing:

and save it to your workflow\public_html\ directory, which generally will be found at: C:\Program Files\ProcessMaker\apps\processmaker\htdocs\workflow\public_html\

Then, open your web browser and direct it to http://localhost/info.php to verify that the pdo_mssql and mssql extensions are enabled in PHP.
Really? I have to dick around with notepad just to see that? OK, I do all that and it gives me

Forbidden: You don't have permission to access /info.php on this server.

Nice. but it browses to html files in the same dir, so it's not a file permissions issue. Must be something to do with php. So I load up good ol' Bitnami ProcessMaker Open Source Edition Stack, go to "Open phpMyAdmin" and find the adminisration screen asking me for a login I was never asked to create, and don't know.

Now what? I start googling and find a lot of people that had trouble connecting in 2010 and a message confusing SQL Server and Oracle. There are instructions on the wiki about making a UTF-8 connection to a MSSQL database, OK maybe that will tell me something.
Open the php.ini file
Comment the old extension=php_mssql.dll and the new extension=php_dblib.dll
Wait. Not only is this coming up with more lines that aren't in the ini file, now we're talking php_mssql.dll instead of mssql.dll. WTF? Was I supposed to get those dlls instead for all that I tried above? I do some more googling and find php mssql drivers that bear no resemblance to either.

I look at the documentation for version 2 ( ... SQL_Server) and it even suffers from copy-paste neglect:
PostgreSQL should now be an available option under theEngine dropdown box.
So in desperation I install the entire SQL Sever engine on my server and restart everything. Of course, SQL still doesn't appear in the dropdown.

So, yeah. You can imagine how I'm feeling about PM. Any ideas before I make recommendations to my boss?
Hey... MSSQL is perfectly working with processmaker. You just need to follow wiki, be patient and keep calm. need to have the entire mssql on the same machine.

Use freeTDS also for your windows enviroment.
In your php load this
Follow ... SQL_Server and ... on_Windows

... to your boss?! ... don't forget that you have downloaded processmaker for free!
The following common scenarios can cause connectivity problems: Incorrect IP address for the Server field. Make sure that the IP address matches the entry in the SQL Server error log file. The incorrect server name in the Server field.

Hope You Find This Useful,
Participated folder

Hello Everyone, Some of the user are experiencing[…]

Hello muavevinwonder, Please take a look at the l[…]

Hello sgtourism176 , Please elaborate a bit more […]

SMS Gateway

SMSala Provider will Provide the Best SMS Gateway […]