Ask questions about your install or get help installing and configuring ProcessMaker 2

Moderator: ArturoRobles

Hi There..

I was hoping that someone could help me on the problem that I had installing PM manually on Windows server 2012. FYI, i manually install the php, apache and mysql as well. The problem is with email, up till login in to smtp server ( was ok, but sending gives me the below error meaase:

"Resolving Host Name:
Checking port: 465
Establishing connection to host:
Login as: [email protected] On SMTP Server
Sending a test mail to: [email protected]
Unable to execute INSERT statement. [wrapped: Could not execute update [Native Error: Table 'wf_workflow.app_message' doesn't exist] [User Info: INSERT INTO APP_MESSAGE (`APP_MSG_UID`,`MSG_UID`,`APP_UID`,`DEL_INDEX`,`APP_MSG_TYPE`,`APP_MSG_SUBJECT`,`APP_MSG_FROM`,`APP_MSG_TO`,`APP_MSG_BODY`,`APP_MSG_DATE`,`APP_MSG_CC`,`APP_MSG_BCC`,`APP_MSG_TEMPLATE`,`APP_MSG_STATUS`,`APP_MSG_ATTACH`,`APP_MSG_SEND_DATE`,`APP_MSG_SHOW_MESSAGE`,`APP_MSG_ERROR`) VALUES ('457153320562f3bdbd8a5f3006981285','','',0,'TEST','Test Email','GP-Test ','[email protected]','\n \n \n \n \n \n \n \n \n \n \n \n
\n \n
\n ProcessMaker Test Email [04:54:51] - SMTP (PHPMailer)\n
\n This Business Process is powered by ProcessMaker ver.\n
\n \n
','2015-10-27 04:54:51','','','','pending','a:1:{i:0;s:0:\"\";}','2015-10-27 04:54:51',1,'')]]

I noticed there was a bug trace reported on this issue but i failed to find any resolution on the problem. Would greatly appreciate any feedback, thanks.

if you are installing ProcessMaker 3.0.x make sure that you're installing
>> PHP 5.5
>> Apache 2.4
>> Mysql 5.5

If you're using other stack this can cause some issues. Because each version of ProcessMaker has been tested with their stacks.

If you're using MySql 5.6 make sure to disable sql_mode

You can use the following query:

>> SET GLOBAL sql_mode = '';
i upgraded from 2.0.44 to 2.0.45, and i using windows server 64 bit
i tried to install the fresh installation of version 2.0.45 on anther server that problem not available , So the problem happens Specifically after upgrading to 2.0.45 !
i tried to delete /opt/processmaker/shared/compiled , but that not solved the problem !
Last edited by iosman987 on Wed Mar 18, 2020 2:41 pm, edited 1 time in total.
You get this error because your main database doesn't have app_message table after your upgrade.
You have error in your upgrade or your upgrade didn't execute completely.

Please export app_message table structure from your new installation and import it in your current database.

I solve the problem using this trigger $caseId =[…]

First off I am new to processmaker. I am trying to[…]

Total of grid in integer

Hi, Is there any better way to do it instead of c[…]

Hi All, I am using 3.5 version and everything work[…]