Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
By richvle
#827016
Hi,
I haven't had this issue before until now. I have multiple dynaforms, including 1 called "Summary". In the Summary dynaform, I have a multiple file upload control. However, any files that are uploaded to it, isn't accessible by anybody. In the Process Permissions, I added everybody and all groups (for testing purposes) and that didn't work. I made sure the permissions were set for NO for participated. However, when set the Summary setting to point to a dynaform that's used in the flow, the attachments show up. So I cloned the dynaform that work, and renamed it Summary and tried it, and it failed. That let me to suspect that the attachments were only showing up if it actually appears in the flow. So I added Summary as a step and viola, it works.

This doesn't make sense to me since I have done this correctly in other processes as well. What could I be missing?

Please see my attachment for the process.
Attachments
By richvle
#827041
It doesn't show an error, it just doesn't show the attachments in the Summary. On the process change "Dynaform to show a case summary:" to "MainForm_Submit Request" (which is part of the flow) and you can see the attachments. But if you change it to "MainForm_Summary View" it won't. Even though "MainForm_Summary View" is a clone of "MainForm_Submit Request". However, if I added "MainForm_Summary View" to SecurityAdmin_A2Z Review task as another step, and just step through it, the attachments will show up. That leads me to believe it's not showing because it wasn't a part of the flow. Which doesn't make sense.
image002.png
image002.png (83.84 KiB) Viewed 177 times
image001.png
image001.png (59.66 KiB) Viewed 177 times
#827078
programerboy wrote: Wed Nov 27, 2019 5:54 am Hi,

I tested your process and run it and then check the participated inbox and click on summary form and it's true.
I attached my picture:
request process.png

Can you send me what error you get?
meilleur taux
https://www.youtube.com/channel/UCYiyz1 ... jMXodwH1iw
Thanks
Hi, I will want to know more about it
Or what exactly are we talking about here? Thank you
By richvle
#827085
I am only able to download the files for the Summary dynaforms that actually show the files.
programerboy wrote: Thu Nov 28, 2019 1:05 am Hi,
I tested with "MainForm_Summary View" dynaform and every thing is ok.
I use processmaker 3.4.2.

Can you download the files?
Please enable the inspect element on the browser to check for errors and check for server-side error?

https://www.youtube.com/channel/UCYiyz1 ... jMXodwH1iw
Thanks

Hi. Have you tried to use JavaScript on your Dyn[…]

Hi Please, could you send information about the c[…]

Dashboard issue

Can you show me what you were trying to do in orde[…]

I want to make the Jalali calendar in all of[…]