Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderator: amosbatto

User avatar
By amosbatto
#826496
Edit the file workflow/public_html/index.html and change the line:
Code: Select all
    <meta http-equiv="REFRESH" content="0;URL=sys/en/neoclassic/login/login" />
To:
Code: Select all
    <meta http-equiv="REFRESH" content="0;URL=sysworkflow/en/neoclassic/login/login" />

Edit your pmos.conf file and inside the virtualhost definition add the line:
Code: Select all
        Redirect /sys/en/neoclassic/login/login http://win-eim4hfisnsj/sysworkflow/en/neoclassic/login/login
Here is an example on my machine:
Code: Select all
<VirtualHost localhost>
    ServerName "localhost"

    DocumentRoot /opt/pm3.3.10/workflow/public_html
    DirectoryIndex index.html index.php

    <Directory /opt/pm3.3.10/workflow/public_html>
        Options Indexes FollowSymLinks MultiViews
        AddDefaultCharset UTF-8
        AllowOverride None
        Require all granted
        ExpiresActive On

        #added to redirect to the "workflow" workspace:
        Redirect /sys/en/neoclassic/login/login http://localhost/sysworkflow/en/neoclassic/login/login

        <IfModule mod_rewrite.c>
            RewriteEngine On
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteRule ^.*/(.*)$ app.php [QSA,L,NC]
        </IfModule>
        AddOutputFilterByType DEFLATE text/html
    </Directory>
</VirtualHost>
By eventoteam
#826501
@amosbatto: Thankyou so much, it worked.

Also, can you guide me, how can i remove this popup?
Attachments
PM.png
PM.png (250.8 KiB) Viewed 813 times
By eventoteam
#826600
Amosbatto: I was doing the same steps for redirecting my older version PM. but my URL seems quite strange. "login.html" appearing two times
Attachments
pic.png
pic.png (1.42 KiB) Viewed 716 times
By eventoteam
#826603
amosbatto wrote: Fri Sep 20, 2019 11:26 am What version of ProcessMaker?

Post the contents of your workflow/public_html/index.html and pmos.conf files
My Company is using 1.245 version. Index files is not attaching so i am adding the code in post.
Code: Select all
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
  <meta http-equiv="content-type" content="text/html; charset=iso-8859-1">
  <title>Tracker</title>
  <meta http-equiv="PRAGMA" content="NO-CACHE">
  <meta http-equiv="CACHE-CONTROL" content="NO-STORE">
  <meta http-equiv="REFRESH" content="0;URL=/sysworkflow/en/green/login/login">
  <link rel="icon" href="images/favicon.ico" type="image/x-icon">
  <link rel="shortcut icon" href="images/favicon.ico" type="image/x-icon">
  <script type="text/javascript" src="browser_message.js" language="javascript">
  </script>
  <link href="masterstylesheet.css" rel="stylesheet" type="text/css">
</head>

<body onLoad="checkBrowser();">
<p></p>

<table width="90%" border="0" align="center" cellpadding="3" cellspacing="5" class="StylishSection">
  <tbody>
    <tr>
      <td width="14%" height="62"></td>
      <td width="76%" align="center"><img src="images/Logo.png"
        alt=" logo" width="360" height="65"
        title="Powered by Tracker Team"></td>
      <td width="10%"></td>
    </tr>
    <tr>
      <td height="66"></td>
      <td align="center" valign="middle" class="style1">Redirecting to Login screen in <span id="theTime" class="style1"></span> seconds. </td>
      <td></td>
    </tr>
    <tr>
      <td colspan="3" align="center">For the impatient ones, <a
        href="/sysworkflow/en/green/login/login.html">click here to go to
        Tracker NOW.</a></td>
    </tr>
    <tr>
      <td colspan="3" align="left" valign="top"><p class="notificationsHeaders">interested in Latest news ? </p>
        <blockquote>
         Click here to see  <a href="news_archive.php">news archive</a>. 
        </blockquote>
        <p class="notificationsHeaders">Interested in FAQs </p>
        <blockquote>
          <p>Click here to see <a href="tracker_faqs.php"> Tracker FAQs </a>.        <br>
          </p>
          <p>&nbsp; </p>
        </blockquote></td>
    </tr>
  </tbody>
</table>
</body>
</html>
Attachments
(1.1 KiB) Downloaded 6 times
printer not connecting

I have a hp printer. I decided to connect my hp pr[…]

Send information from PM to SAP

Hi team, i have a question, is possible send info[…]

Subprocesso

Olá, alguém pode me ajudar na utiliz[…]

I am trying to make file upload field mandatory u[…]