Le Forum de la Communauté française - Forum for French speakers

Moderators: amosbatto, mjaenvar

By SwiFFeR
#825168
Hello

I'm working on a web application that uses Processmaker,
I've noticed that my connection via the Rest API only works with users like 'Adminstrator' or 'Manager', but doesn't work with a user 'Operator'.
I would like to know if there is a track to explore to address this problem or if anyone has ever encountered this problem.

Thank you in advance for your help.
User avatar
By amosbatto
#825171
What version of ProcessMaker are you using? I can login with oAuth2 with the Operator role in PM 3.3.8 Community.

Do you have the default permissions in your Operator role?

PS: As a side note, you might want to check out the extraRest endpoints, because they will help you get around many limitations with the official REST endpoints.
By SwiFFeR
#825216
amosbatto wrote: Fri Jun 28, 2019 7:46 pm What version of ProcessMaker are you using? I can login with oAuth2 with the Operator role in PM 3.3.8 Community.

Do you have the default permissions in your Operator role?

PS: As a side note, you might want to check out the extraRest endpoints, because they will help you get around many limitations with the official REST endpoints.

I use ProcessMaker 3.2.1 community, and yes i have the default permissions in the Operator role.
User avatar
By amosbatto
#825235
In PM 3.2.1 Community, I just tried logging in with a user with the Operator role, and it works.

Check if the user's account has expired.
Is this user imported with LDAP? You should be able to login with an LDAP users, but just to be safe, create a normal user in ProcessMaker who doesn't use LDAP and try it again.

@{ var result = ""; if (IsPost) […]

Hi, Could you explain to me what is the differenc[…]

Routing Logic

Thanks Amos, will do it how u recommended.

Did you set up your ProcessMaker server to periodi[…]