Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By ivanchopolis
Hi, I have a problem in order to log to processmaker. When I install processmaker in ubuntu, I can enter successfully to the web application once, but when I restart my server, I use my user and key in the log page and I can not enter, the web page just reload as if a component failed. Do you know how can I fix this problem or do you know how can I access to the checklist that is showed in the installation process where the components are listed with a check?. I have installed processmaker many times and always I get the same problem.

Thanks for your help.

User avatar
By amosbatto
What version of ProcessMaker? Manual or Bitnami install? If manual, what page did you follow to do the installation? What version of Ubuntu?
When you try to login the second time what exactly do you see? If you press F12 to open the web browser's debugger and go to the "Network" or "Net" tab, do you see any page that failed? If you go to "Console", do you see any JavaScript errors?
By ivanchopolis
Thanks for you help Amos.

Regarding your questions, I installed the manual version with the installation manual for Processmaker 3.3. in Ubuntu 18.04 ... stallation and I have Ubuntu 16.04, I can not see any errors with f12 in the page or java scripts. In the attached is the print screen of what I see, if you have an email, I can send you my URL.

Again thanks for your help.

PM.png (705.46 KiB) Viewed 2359 times
User avatar
By amosbatto
With Ubuntu 16.04, you could have used the versiones of PHP and MySQL which are included in the Ubuntu repositories, so it wasn't necessary to follow those instructions, but they should still work.

In your env.ini file add the line:
debug = 1

Do you see any error messages now when you try to login?
User avatar
By amosbatto
ivanchopolis wrote:Hi Amos, I flaged the debug=1 but the errors are not showed, do you have another idea?


No ideas, aside from rebooting (in case you haven't tried that).

I installed PM 3.2 in Ubuntu 16.04 without any problems, but I haven't tried PM 3.3 and I don't have time today and tomorrow is a national holiday here in Bolivia. Next week, I'll try installing PM 3.3 in Ubuntu 16.04 and get back to you. I wrote up the instructions to install PM 3.3 in Ubuntu 18.04 on the wiki, so I know that works if you feel like upgrading.
Cannot upload CSV

Hi, I am using a multi-file upload. When I upload[…]

A Beginner's Guide for ProcessMaker

I recently completed a book on ProcessMaker - &q[…]

Hi guys. I am a newbie. I don't know how to upgrad[…]

HI Thanks so much! This is just what I need.