Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderator: amosbatto

When I try to import a plugin it never shows up in the window even though it has been uploaded into the correct folder as I can see it in my home/XXXXX/processmaker-3.3.6-0/apps/processmaker/htdocs/workflow/engine/plugins folder both the .php file and the folder.

None of the plugins are showing even the ones which I am guessing come with the bare install.

Is this a permissions issue? I have read on other topics that I should change the owner to www-data however that group does not seem to be their. Anyone know which group the Bitnami stack runs as?

I seem to be having the same issue with the skins as two are showing but I can see others in the folder /home/xxxxx/processmaker-3.3.6-0/apps/processmaker/htdocs/workflow/engine/skinEngine

Last edited by Nickvermeulen on Wed Apr 10, 2019 4:48 am, edited 1 time in total.
Still trying to figure this out. Thought I would look at the skins issue as not getting anywhere with the plugins.

So when I read the documentation
Screenshot from 2019-04-10 09-23-54.png
Screenshot from 2019-04-10 09-23-54.png (28.7 KiB) Viewed 1666 times
shows the file location. When I look at that location I can see:
Screenshot from 2019-04-10 09-22-25.png
Screenshot from 2019-04-10 09-22-25.png (44.95 KiB) Viewed 1666 times
Are the other folders in here meant to be showing in the Skins area or are they part of the UX Experience drop down?
Screenshot from 2019-04-10 09-27-52.png
Screenshot from 2019-04-10 09-27-52.png (14.25 KiB) Viewed 1666 times
Thanks for any direction
So I found some skin.tar files and there is no issue with uploading them. The files are stored in another folder
Screenshot from 2019-04-10 09-43-14.png
Screenshot from 2019-04-10 09-43-14.png (30.38 KiB) Viewed 1665 times
and do appear in the admin page
Screenshot from 2019-04-10 09-41-07.png
Screenshot from 2019-04-10 09-41-07.png (21.47 KiB) Viewed 1665 times
So I am still not sure why the plugins don't appear in the admin page when I upload them.

Any pointers gratefully received!

So I have downloaded the three tar packages on the PMUsers site to check that it is not an issue with my plugins that is causing the issue.

The process is clearly kicking off as I get the following error when trying to import one of the packages.
Screenshot from 2019-04-10 10-34-12.png
Screenshot from 2019-04-10 10-34-12.png (21.8 KiB) Viewed 1659 times
So it seems that plugin is not complete.

The other packages are still not showing up in the manager.

Delete all the plugin files that you added in the workflow/engine/plugins/ directory.

Then, try to import this file: ... ns-1.2.tar

Does it work now?

If not, then try this to make sure it isn't a file permissions problem:
chmod -R 777 workflow/engine/plugins

PS: Bitnami in Linux uses the "daemon" user to run Apache.

You are the man!

So I have tried this on both the enterprise and community version. What did the trick was deleting the existing plugins that are in the install. Some of them must be in the install as there is one called charts in there which I had not imported.

I had to rename your tar file to have a lower case e as it would not install. Once I did that it appeared. I have been able to install the extraRest plugin and the two I have written.

As soon as I tried to install the custom functions tar it loads it into the directory but all the plugins disappear. Deleting the custom function directory and php file brings them back.

Has the way the tar packages are built changed?

Thanks for helping with this was driving me mad.


(75 KiB) Downloaded 50 times
Unfortunately, Wikimedia always converts filenames that start with a lower case letter to upper case. I forgot about that when I uploaded the file. I will move the .tar file outside Mediawiki to avoid that problem.

What happened with the old plugins is that they don't function in PHP 7.0 and later, because they take a reference to an object that is already a reference. PHP changed the rules and no longer allows that. To fix that, you have to edit the workflow/engine/plugins/pluginName.php file and change the line from:
$oPluginRegistry = &PMPluginRegistry::getSingleton();
$oPluginRegistry = PMPluginRegistry::getSingleton();

Hi, I have a problem with iteration of subprocess[…]

I am creating an application using the Process Mak[…]

Hi guys, I recently landed into processmaker commu[…]

Thank you Ricardo, I am upgrading it to 3.4.11 Is[…]