Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

#817672
Hi PM,

Details:
Processmaker version 2.5.1
Web Server: Apache/2.2.15 (CentIOS)
PHP Version : 5.4.x
Database: Mysql

Web Services
executeTrigger
routCase

We are using multiple webservices of processmaker and takes too long to finish one record. Is there anything that we could tweak to optimize or speed up the processing of these services?

Hoping to hear from you.

Thanks.
#817678
Either add these lines to your PHP script:
Code: Select all
ini_set("soap.wsdl_cache_enabled", "0");
ini_set("max_execution_time", "0");
Or set these lines in your php.ini file:
Code: Select all
soap.wsdl_cache_enabled = On
max_execution_time = 0
#817764
Did you use ini_set()? I often find that ini_set() doesn't work correctly, so I have to put the changes in the php.ini file and restart Apache for the changes to take effect.

If that isn't the problem, then you can try increasing the memory_limit setting in your php.ini file.

If that still doesn't solve the problem, then you need to provide the code that is causing the problem and the error messages that are generated (without hiding the vital info).
#817770
amosbatto wrote: Thu Nov 08, 2018 11:20 pm Either add these lines to your PHP script:
Code: Select all
ini_set("soap.wsdl_cache_enabled", "0");
ini_set("max_execution_time", "0");
Or set these lines in your php.ini file:
Code: Select all
soap.wsdl_cache_enabled = On[/color]
max_execution_time = 0

Hi Amosbatto,
I should disable the soap.wsdl_cache_enabled = 0 or soap.wsdl_cache_enabled = Off?
#817778
The WSDL cache should be enabled:
Code: Select all
soap.wsdl_cache_enabled = On
If a web service call can't be immediately executed, then it will be cached and executed later.
Are you making many web services calls in a row?
#817780
amosbatto wrote: Wed Nov 14, 2018 6:38 pm The WSDL cache should be enabled:
Code: Select all
soap.wsdl_cache_enabled = On
If a web service call can't be immediately executed, then it will be cached and executed later.
Are you making many web services calls in a row?
I set the it to
Code: Select all
soap.wsdl_cache_enabled = 0
instead. Yes, multiple webservices calls are being called in one loop.
This is the flow inside the loop with the soap calls:
- login = > executeTrigger = >executeTrigger => routeCase;


Thanks.
#817796
I think that you should be enabling wsdl caching or you should add sleep(10000); to your script to periodically rest (or you should set the script to execute periodically as a cronjob).

If you are executing this script from the command line, then some LInux distros have a separate php.ini file for the command line. For example in Debian 9, you need to edit /etc/php/5.6/cli/php.ini .

Also, you should make sure that max_input_time = -1 (or isn't set in your php.ini file), so that the max_execution_time setting will be used.

Good morning Amo, I am using ProcessMaker 3.2.2, […]

Hi Processmaker Team, after upgrading from 2.0.45[…]

Un solo checkbox en un grid

Buen día amossbatto Creo que no entendist[…]

Is there any way this can be done using a php trig[…]