Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
User avatar
By jemiris
#796015
My Problem:

1. While saving the process its displays as a error saving process.
2. Why the error saving process occurs
User avatar
By amosbatto
#796018
What version of PM and what operating system? What is the exact error message? Have you checked the error logs?
For example, in Debian 8.4:
/var/log/apache2/error.log
/var/log/apache2/access.log
/var/log/mysql.err
/var/log/mysql/error.log
/opt/processmaker/shared/sites/workflow/log/processmaker-2017-XX-XX.log
You can also turn on PHP error log file in your php.ini file.
User avatar
By jemiris
#796090
Hi forum,

While saving the process i got an error. Im using windows 8 and 3.1.3 process maker version.
Attachments
error_saving_process.PNG
error_saving_process.PNG (35.73 KiB) Viewed 2067 times
User avatar
By amosbatto
#796098
That doesn't tell me much. Can you export the process and post it on the forum?
If you can't export the process, then you will have to check the error logs, because there is no other way to tell what is the problem.
User avatar
By jemiris
#812656
Yes i found the solution for it. Because i didn't give the permission for the particular process, so that it's not allowed me to do any action. Thanks
By richvle
#824496
I started a new process from scratch, because I was receiving the "Error Saving Process". Inside the access.log, I got this:

192.168.188.105 - - [17/May/2019:14:01:02 -0700] "PUT /api/1.0/workflow/project/4248962405cddc1c4beef17083194469 HTTP/1.1" 400 281
192.168.188.105 - - [17/May/2019:14:01:38 -0700] "PUT /api/1.0/workflow/project/4248962405cddc1c4beef17083194469 HTTP/1.1" 400 281

Any idea what the 281 is for?

I've attached the process file as well.
Attachments
(396.03 KiB) Downloaded 28 times
User avatar
By amosbatto
#824509
richvle, I have no idea what the numbers mean. That is the REST endpoint to save your process when working in the process designer.

I'm able to import and change your process without any problem. Do you still see the same error or did it only appear once?
By richvle
#824534
Hi Amos,
I was able to replicate the saving issue by importing on to other servers. I found out how to replicate it, but not consistently. I was able to trace it back to the exclusive gateway. I removed the default flow option, and added an additional routing rule to replace the default option, and that fixed it. I noticed that problem came up again in my other gateways, so I basically just removed all default flow options.
Capture3.JPG
Capture3.JPG (77.84 KiB) Viewed 1383 times
amosbatto wrote: Mon May 20, 2019 11:13 pm richvle, I have no idea what the numbers mean. That is the REST endpoint to save your process when working in the process designer.

I'm able to import and change your process without any problem. Do you still see the same error or did it only appear once?
User avatar
By amosbatto
#824542
Which version are you using? I didn't see the problem in PM 3.3.8, when I tried to save.
You should register a bug report about it.
By richvle
#824552
Version 3.1.1 Community.

I've also reported it as a bug with case ID #0027716.
amosbatto wrote: Tue May 21, 2019 8:26 pm Which version are you using? I didn't see the problem in PM 3.3.8, when I tried to save.
You should register a bug report about it.
mysqli_free_result() error

Hi Amos We are using a hosted version so I don't […]

Sorry, but I don't know vue.js very well. Dealin[…]

The condition is not workable

If you want help, then you need to post your condi[…]

To remove the other red asterisk in the field's la[…]