Page 1 of 1

Problems to download the input documents larger than 50 MB

Posted: Fri Mar 08, 2013 1:58 pm
by kaifamm
Hi,

I have problems to download my input documents in cases if the attachment is larger than 50 Mb with this message :

Page not found : http://localhost:8181/sysworkflow/en/de ... 195662&v=1

in chrome browser : Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

in firefox : File not found

If I try with a little file it works and the upload works correctly. It is only the download that doesn't works.
My php.ini it's correct .

I have x86_64 :
httpd-2.2.22
php-5.3.8
PM 2.0.45


Thank you
Mark

Re: Problems to download the input documents larger than 50

Posted: Fri Mar 08, 2013 3:06 pm
by liliana
Hi,

Did you set the following parameters as below?:

post_max_size = 256M
upload_max_filesize = 256M

Those on your php.ini, don't forget to restart apache.

then increase memory limit on the env.inifile.

Regards.

Re: Problems to download the input documents larger than 50

Posted: Sat Mar 09, 2013 9:15 am
by kaifamm
Hi
thank you for your reply.

I put in my engine/config/env.ini memory_limit = "200M" but it doesn't works, then i changed in my public_html/sysGeneric.php from ini_set('memory_limit', $config['memory_limit']); to ini_set('memory_limit', '400M') and it works.

Why it doesn't take the env.ini variables ?

Thank you again
Mark

Re: Problems to download the input documents larger than 50

Posted: Sat Mar 09, 2013 11:23 am
by ronrich
you should change this settings in the php.ini file like Liliana told you

post_max_size = 256M
upload_max_filesize = 256M

and the memory limit in the env.ini file

this should works

Good luck

Ronald

Re: Problems to download the input documents larger than 50

Posted: Mon Mar 11, 2013 9:01 am
by kaifamm
Hi,
thanks for the reply, maybe I have not explained well, thanks to my bad English.

My php.ini has always been correct, but in my env.ini was: memory_limit = "80M", I carried it to 200M but it did not work, only going in public_html/sysGeneric.php and putting ini_set ('memory_limit ', '200M') works. Why?

Thanks again
Mark

Re: Problems to download the input documents larger than 50

Posted: Tue Mar 12, 2013 5:25 pm
by liliana
Hi,

Don't worry about your English, which version of ProcessMaker are you using, maybe this is a bug, but I'd like to confirm the issue first. Anyway, did you restart apache?, did you change the value from ProcessMaker, means by going to Admin>Settings>System? or did you change the value by going directly to the file?, maybe at some point the file is being overwritten that's why it does not respect the value.

Regards.

Re: Problems to download the input documents larger than 50 MB

Posted: Tue Sep 11, 2018 10:50 pm
by amosbatto
maria024,
All I need to do is change the settings in the workflow/engine/config/env.ini file with manual installs of ProcessMaker in CentOS 7, Debian in 8.5, Debian 9.5 and Ubuntu 16.04.
What version of ProcessMaker and what OS do you have? Do you have a manual or Bitnami installation?

Re: Problems to download the input documents larger than 50 MB

Posted: Sat Mar 07, 2020 2:54 am
by CashApp
Want a solution for transferring your money through mobile, we have mastered the art of providing the system for money transaction highly optimized for mobile, check cash app customer service assistance by visiting at: https://www.apponlinesolutions.com