Share ideas, ask questions, and get feedback about developing for ProcessMaker

Moderator: amosbatto

Forum rules: Please post new questions under "Developing processes & programming" for ProcessMaker 2 or 3.
#50347
Hi,

I have problems to download my input documents in cases if the attachment is larger than 50 Mb with this message :

Page not found : http://localhost:8181/sysworkflow/en/de ... 195662&v=1

in chrome browser : Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found.

in firefox : File not found

If I try with a little file it works and the upload works correctly. It is only the download that doesn't works.
My php.ini it's correct .

I have x86_64 :
httpd-2.2.22
php-5.3.8
PM 2.0.45


Thank you
Mark
#50535
Hi
thank you for your reply.

I put in my engine/config/env.ini memory_limit = "200M" but it doesn't works, then i changed in my public_html/sysGeneric.php from ini_set('memory_limit', $config['memory_limit']); to ini_set('memory_limit', '400M') and it works.

Why it doesn't take the env.ini variables ?

Thank you again
Mark
#51005
Hi,
thanks for the reply, maybe I have not explained well, thanks to my bad English.

My php.ini has always been correct, but in my env.ini was: memory_limit = "80M", I carried it to 200M but it did not work, only going in public_html/sysGeneric.php and putting ini_set ('memory_limit ', '200M') works. Why?

Thanks again
Mark
#51486
Hi,

Don't worry about your English, which version of ProcessMaker are you using, maybe this is a bug, but I'd like to confirm the issue first. Anyway, did you restart apache?, did you change the value from ProcessMaker, means by going to Admin>Settings>System? or did you change the value by going directly to the file?, maybe at some point the file is being overwritten that's why it does not respect the value.

Regards.
#816008
maria024,
All I need to do is change the settings in the workflow/engine/config/env.ini file with manual installs of ProcessMaker in CentOS 7, Debian in 8.5, Debian 9.5 and Ubuntu 16.04.
What version of ProcessMaker and what OS do you have? Do you have a manual or Bitnami installation?

Thanks for your reply, Press F12 in your web bro[…]

I created a new process to make it easier to look […]

Genial!!! gracias. :D

This is resolved. I took a punt on Amos' suggesti[…]