Questions and discussion about using ProcessMaker 2: user interface, running cases and functionality

Moderators: ArturoRobles, ArturoRobles

Forum rules: Please search to see if a question has already been asked before posting. Please don't ask the same question in multiple forums.
By edcolon
#826943
Hi,

this is a little tricky, so first I will set my environment:
Suse 11 SP2 /PHP 5.3.3 / Mysql 5.1.73
Processmaker 2.0.43

If I configure an email account like this:
****************************
Email Engine: SMTP (PHPMailer)
Server: stmpapp.existing_internal_domain.com
Port: 25
Account: [email protected]_internal_domain.com
Require authentication (no)
Send test email
mail to: <my own email>
***************************
Have in mind that this account "[email protected]_internal_domain.com" actually does not exist.

Then... TEST -> TESTING RESULT IS OK (EMAIL IS RECEIVED)

Then I create a single process with 1 task.
Task 1: I enable default notifications either plain text or html (previously created), then the email is SENT... 'till here everything is ok.

When I create a TRIGGER to send it by PMFSendMessage, the email IS NOT SENT. Here is the code:
@@__ERROR__="";
G::LoadClass("pmFunctions");
@@valida=PMFSendMessage(@@APPLICATION, "[email protected]_internal_domain.com", '[email protected]', '', '',
"Por Trigger", "demo.html");
If I debug the process, @@valida=0

I don´t know why the code is not working.

My search:
1. Before I had PHP 5.2.5 and it worked, now I have PHP 5.3.3 and does not.
2. In order to make Processmaker works with PHP 5.3.3 I added a line in pmos.conf file:
...... ALL PMOS STUFF BASED ON WIKI
.....
</Directory>
header set Content-Security-Policy "default-src 'self' data: gap: https://ssl.gstatic.com 'unsafe-eval'; style-src 'self' 'unsafe-inline'; media-src *;script-src 'self' http://onlineerp.solution.quebec 'unsafe-inline' 'unsafe-eval'; "
</VirtualHost>

3. If I execute cron.php to see if they would be sent, the error in /opt/processmaker/shared/log/cronError.log is:
.........
<date> <hour> (resendEmails) Error Resending Emails: Could not access file:
<date> <hour> (resendEmails) Error Resending Emails: Could not access file: Array

4. If I try with my own account (which is not advisable for me) to configure and execute the trigger, the email IS SENT.

By any chance do you know what is happening and how to fix it?

Thanks a lot guys.
By edcolon
#827060
The solution to this problem is as follows:
locate file: class.spool.php
Check near line 340 and comment it:
Code: Select all
//$oPHPMailer->SMTPAuth = (isset($this->config['SMTPAuth']) ? $this->config['SMTPAuth'] : '');
Right under that commented line, add the following code:
$oPHPMailer->SMTPAuth = '';

Then, locate the file: class.wsBase.php
Check near line 726:
$oSpool->setConfig(array(
'MESS_ENGINE' => $aSetup['MESS_ENGINE'],
'MESS_SERVER' => $aSetup['MESS_SERVER'],
'MESS_PORT' => $aSetup['MESS_PORT'],
'MESS_ACCOUNT' => $aSetup['MESS_ACCOUNT'],
'MESS_PASSWORD' => $aSetup['MESS_PASSWORD'],
// Add the following line:
// *****************************
Code: Select all
     'SMTPSecure'    => $aSetup['SMTPSecure'],
// *****************************
'SMTPAuth' => $aSetup['MESS_RAUTH']
));

Test it, for me it works perfectly.
Thanks to Maui from Processmaker support.

Regards.

@Ed
Timeout Not Sending Email

I am confused, but I have setup a self-service as[…]

Hello; In a dynaform (for example: called "Gr[…]

issue with processmaker 3.2

Ok thank you but i have more questions For exam[…]

No, there's nothing wrong in the browser network a[…]