Questions and discussion about using ProcessMaker 2: user interface, running cases and functionality

Moderators: ArturoRobles, ArturoRobles

Forum rules: Please search to see if a question has already been asked before posting. Please don't ask the same question in multiple forums.
Dear PM Support Team,

Recently most of our users using the latest version of Firefox (66.0.2) have reported that double digit is occurring.
Is this a known issue as we recommended our PM users to always use Mozilla Firefox when using Processmaker?

Are there any workaround aside from downgrading their Firefox browser? We are using PM ver. 2.5.2

Thank you in advance.

Hi amosbatto,

Same issue what is occurring if you are using Internet Explorer. Attached to this message is the screenshot.

I entered 123 but it display 112233. This issue is happening on the latest version of FireFox.

Add description
112233.png (11.86 KiB) Viewed 2861 times

copy the source "gulliver\js\form\core\form.js" from the last version and paste in your version. (get backup first) Your problem will solved.
After replace source, I changed this code (You can only change this code without any replace source):
Code: Select all
if (!window.event){
      this.element.onkeydown  = this.handleKeyDown;
Code: Select all
  if ( == 'Firefox'){
  //if (!window.event){
      this.element.onkeydown  = this.handleKeyDown;
The problem is for onkeypress event handle in firefox.

Hi programerboy,

Thank you for your reply regarding the issue on double digit in FireFox.

What do you mean by "copy the source "gulliver\js\form\core\form.js from the last version"?

I tried to change that part in form.js and saved the changes but still the double digit issue is still occurring.

Could you please let me know if I need to do something else....
form.jpg (53.15 KiB) Viewed 2806 times
Hi SMorel,

May I ask what part of the two files you have modified? Could you please send a screenshot?

Thanks, in advance.

smorel wrote: Tue May 07, 2019 10:48 pm I just made it to work :D
I didn't cover all possible case yet ...
But, there are 2 files to update
-> gulliver\js\form\core\form.js (as stated)
-> gulliver\js\maborak\core\maborak.js

Thanks for the advice

As of now I'm still having this problem.

Timeout Not Sending Email

I am confused, but I have setup a self-service as[…]

Hello; In a dynaform (for example: called "Gr[…]

issue with processmaker 3.2

Ok thank you but i have more questions For exam[…]