Questions and discussion about using ProcessMaker 2: user interface, running cases and functionality

Moderator: ArturoRobles

Forum rules: Please search to see if a question has already been asked before posting. Please don't ask the same question in multiple forums.
By denity
Hi everyone,

I'm new to processmaker, and I want to use the web service interface to integrate processmaker and my own system, such as OA. But when I try "Web services test" in "Settings" menu, I always got this error:

SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://localhost:9092/sysworkflow/en/cl ... ices/wsdl2' : Start tag expected, '<' not found

Is there someone can help me out of this?

thanks a lot.
By denity
Hi liliana,

Thank you very much. I think this might be a bug with "php-5.4.9-vc10-x64" on my localhost. I searched this forum about this problem and tried several times but fail.

I tried setting up parameters in "Web Services Test"->"setup", and tried changing the "pmos2.wsdl", and tried different browsers, and tried setting a domain in windows hosts files which point to, also, I checked php.ini and firewall rules. These all didn't work for me.

I can view the xml file with browser, the url is " ... ices/wsdl2". But in php script,

$soap=new SoapClient(' ... ices/wsdl2', array('cache_wsdl' => 0));

always get the "Start tag expected, '<' not found" error. And I tried some other web services url such as " ... .asmx?wsdl", it's ok. It worked fine.

Finally, I exported a xml file form " ... ices/wsdl2" and used the xml file directly, It worked.

So, I had no idea about this problem. May be there was some conflictions between SoapClient and the web service in processmaker. Please tell me what to do now.

User avatar
By liliana
hi denity,

the problem is we do not support php 5.4 or later versions, that's why you found that problem. Test if everything is working for you now, if not I suggest you to downgrade your PHP version to a 5.3 which we officially support.

Let me know how this is going for you.

By denity
Thank you Liliana,

I went through most basic functions of processmaker open source version, I found most of them working well except "curls" function. Such as soap, web entry and so on.

User avatar
By liliana
So it might be your PHP version, as I suggested if you can downgrade your php version to 5.3 will be great, always backing up your ProcessMaker instance, another solution is to install another ProcessMaker instance using PHP version and run some tests there.


Hello Thanks for Sharing this Information https://[…]

ProcessMaker 3.6 open source

I can see the version 3.7 is available on the link[…]

Community vs Enterprise

Dear PM Forum Admins, Additional question on Comm[…]