Ask questions about your install or get help installing and configuring ProcessMaker 2

Moderators: ArturoRobles, ArturoRobles

By amartinez
#783502
Hello,
I'm trying to install processmaker 2.0.30 to CentOS 7 with the hope that i can perform a restore from a production instance.

I'm to the point where i need to browse to the site for the first time, and i receive many "Strict Standards" errors. I've tried editing /etc/php.ini so that error_reporting reads the following values...

error_reporting = 0
error_reporting = E_ALL & ~E_DEPRECATED
error_reporting = ~E_ALL & ~E_DEPRECATED & ~E_STRICT

i restart apache after each edit, and i continue to see "Strict Standards" errors. I've come to the conclusion that the error_reporting level is being set by processmaker it self, is that correct? how can i fix this?

Help is much appreciated, thank you.

OS: CentOS 7
php: 5.4.16
Apache: 2.4.6
#783535
Hi,

Why are you using an old version of ProcessMaker, the latest stable release is v. 2.8. From v. 3.0 we are supporting PHP 5.4. A lot of users downgrade their PHP versions in order to have ProcessMaker run under CentOS.
#783536
Hello Liliana, and thank you for replying.

I was trying to reproduce our current production environment so I can test an upgrade path.

As you have noticed it is an old version. Can you please tell me what would be the best upgrade path from version 2.0.30 to 3.0?
#783541
Version 3.0 has a new definition since it uses a bpmn concept, if you want to upgrade your current version to 3.0 your processes will work as you expected but you cannot create process in the same designer used until version 2.8.

The upgrade process is the following:

* Upgrade you ProcessMaker version to a 2.0.45 version. Follow this guide in order to upgrade to a v. 2.0.45 and 2.5.2
* Then upgrade it to a 2.5.2 version
* From here you can upgrade either to a 2.8 version or to a 3.0 version.

- Follow this guide to upgrade to v. 2.8
- Follow this guide to upgrade to v. 3.0

These steps are required due to some database changes.

Anything you need just let me know.

Regards,
#783560
Hello,
I have upgraded from 2.5.2 to version 3.0.0.5 in my test environment. I did run into some problems when I ran the command to upgrade the database, ./processmaker upgrade

I received an integrity check warning. I've attached a picture.

I continued past the integrity check, and towards the end of the upgrade script I receive a PHP Notice, Undefined undex: MAIL_TO ... , I've attached a picture of this also.

do you happen to know how these errors will affect the installation? The error "Unable to execute INSERT statement" worries me..
Attachments
php notice.png
php notice and db error
php notice.png (62.51 KiB) Viewed 3459 times
integrity check fail.png
integrity check fail
integrity check fail.png (68.04 KiB) Viewed 3460 times
Last edited by amartinez on Mon Jun 29, 2015 12:18 pm, edited 1 time in total.
#783573
After looking closer at the error, it appears the data that was not inserted into the database were the mail server settings. When I look at the mail server settings in processmaker admin settings it is not displaying properly and I can't edit the settings. See picture attached.

What can I do to resolve this error?
Attachments
email settings not displaying.png
email settings not displaying
email settings not displaying.png (23.96 KiB) Viewed 3459 times
#783575
when I run ./processmaker upgrade , i receive the same php notice error and the same database insert error

when i run ./processmaker translation-upgrade, i receive a Command not found error

After I built the processmaker cache and cleared the browser cache, i experienced the following...
1. Internet Explorer 10 did not load the login page when browsing to the site URL, It gave a "this page can't be displayed" error. It appears that Internet Explorer is not redirecting me to the /sys/en/neoclassic/login/login login page, i came to this conclusion because Firefox worked. If i browse directly to http://processmaker.domain.com/sys/en/n ... ogin/login in internet explorer, the login page loads

2. Firefox 31 was able to load the login page without a problem, it redirects me to /sys/en/neoclassic/login/login to login

3. The email server settings heading continues to display wrong and i can't edit mail server settings.

4. On closer inspection, the email server settings heading may not be the only one displaying wrong, under settings i also see a heading named "**ID_CUSTOM_CASES_LISTS**". I think this heading may be displayed in error? attached is an image
Attachments
settings not displaying properly.png
settings headings not displaying properly
settings not displaying properly.png (31.09 KiB) Viewed 3456 times
#783673
Hello,
I have decided to upgrade to processmaker version 2.8 .

The only thing that stood out during the upgrade to 2.8 was the integrity check failure. I always chose to continue past the integrity check failure.

The only problem i see with version 2.8 is that internet explorer 10 does not automatically redirect to the log in page, instead it gives a "this page can't be displayed" error. However, if i add "/index.html" to the url, the login page loads.

Firefox 31 works as expected.

What can i do to solve this quirky problem with internet explorer? i suspect it has something to do with the rewrite rules. :?:
#783881
Can someone comment on the problem i'm having with version 2.8, internet explorer 10 does not automatically redirect to the log in page, instead it gives a "this page can't be displayed" error. However, if i add "/index.html" to the url, the login page loads.

has anyone else ran into this problem?

As of now I'm still having this problem.

Timeout Not Sending Email

I am confused, but I have setup a self-service as[…]

Hello; In a dynaform (for example: called "Gr[…]

issue with processmaker 3.2

Ok thank you but i have more questions For exam[…]