Ask questions about your install or get help installing and configuring ProcessMaker 2

Moderator: ArturoRobles

The problem appear when you want to assign user or group to task
Tab DESIGNER -> select any process -> right click on Process Title -> Users & user groups - > Assign
When I wish to assign user or group to a task the search filed become blank and no result although the data is exists !
This issue happens in all browsers After upgrading to 2.0.44 and

Any suggest ?
Please note that this problem appears in forms which is have search field such as When i need to assign employee to usergroup (Tab ADMIN->Users->Groups )I wish to add an employee in the group,
so i wrote his name or number, but after click on search, all names appear, not the name i looking for !
I'm still facing the above problem :(
i tried to make upgrade again but useless
I tried to clear Cash from the client and server side but also useless !
see the below picture if to know more the problem ,

Any ideas? any suggest ?
1.PNG (5.16 KiB) Viewed 6971 times
Hi monzer,

Sorry for the late response, I've been trying to reproduce this problem but without any results. Did you upgrade from version 2.0.43 to 2.0.44? and are you using Linux or Windows?,

And one more try, could you delete the entire compiled folder and content located at:
Code: Select all
Let me know if it works please.

Hi liliana
i upgraded from 2.0.44 to 2.0.45, and i using windows server 64 bit
i tried to install the fresh installation of version 2.0.45 on anther server that problem not available , So the problem happens Specifically after upgrading to 2.0.45 !
i tried to delete /opt/processmaker/shared/compiled , but that not solved the problem !

any other ideas?

thanks in advance
Hi monzer,

Another thing to try is check the status of users, maybe they are inactive or on vacation, could you check the status on the database USERS table, please?, and also is it possible for you to try this issue on a Linux installation?, I want to discard the problem, maybe is only a Windows problem, if is, a bug needs to be reported.
There is an intermediate fix for this:

Find the file class.xmlform.php (processmaker\gulliver\system), go to line 4384 and extend the code as follows:

insted of:
Code: Select all
foreach (glob($filesToDelete) as $fileToDelete) {
Code: Select all
if (glob($filesToDelete)){
    foreach (glob($filesToDelete) as $fileToDelete) {
This fixed the problem for me. By the way there are several smaller bugfixes (which were blocking for me) described in the documentation of my SSO plugin: ... IS_SSO.pdf
This is one of them.

Hmm, strange. Can you add debug=1 to your file workflow\engine\config\env.ini and also set display_errors = ON and html_errors = ON in your php.ini file? In my case after doing this I got an error message showing me where the problem was. In this way you could also see, if you did the change in the correct file.


Hello ProcessMakers! We are extremely proud to an[…]

How processmaker load cases on home page of user? […]

Hey everyone, I'd appreciate any help you might be[…]

Error dynaform xml pm3

Thanks for sharing .