Configuring and Installation

Ask questions about your install or get help installing and configuring ProcessMaker 2

Moderator: amosbatto

eventoteam
Posts: 8
Joined: Wed May 17, 2017 1:39 pm
Country: Pakistan

Configuring and Installation

Unread postby eventoteam » Thu Jun 29, 2017 8:47 am

Respected All,

Can anyone help me out in installing and configuring processmaker application.I want to use wamp apache Service and Mysql Server 5.5 MYSQL Service.
Kindly mention all the changes need to be made in conf file or any other file.

Thanks & Regards,

amosbatto
Posts: 5018
Joined: Mon Jun 22, 2009 10:28 am
Country: Bolivia
Location: La Paz

Re: Configuring and Installation

Unread postby amosbatto » Thu Jun 29, 2017 9:23 pm

Two years ago, people on the forum said that they couldn't get ProcessMaker to run on WAMP. It might be possible now, but I haven't tried it.

I recommend that you follow the instructions on the wiki, but also see this post:
viewtopic.php?f=40&t=710347&p=793279
Amos B. Batto ♦ ProcessMaker Technical Documentation Writer & Forum Manager ♦ Cofounder of ILLA-A

eventoteam
Posts: 8
Joined: Wed May 17, 2017 1:39 pm
Country: Pakistan

Re: Configuring and Installation

Unread postby eventoteam » Fri Jun 30, 2017 2:11 am

Respected Sir,

I have followed the Steps mentioned in the thread.
It did help, I have successfully landed on Homepage but when i click to login http://processmaker.dev/sysworkflow/en/green/login/login.html
It Shows the Following errors,I have attached the snapshot of it.

Regards,
Attachments
Error.png
Error Snapshot.
Error.png (98.57 KiB) Viewed 229 times

amosbatto
Posts: 5018
Joined: Mon Jun 22, 2009 10:28 am
Country: Bolivia
Location: La Paz

Re: Configuring and Installation

Unread postby amosbatto » Fri Jun 30, 2017 9:05 pm

First of all, what version of PM are you installing? We haven't used the "green" skin in years. Change the URL to http://processmaker.dev/sysworkflow/en/neoclassic/login/login.html

You need to configure PHP to not show warning messages for deprecated functions. ProcessMaker uses some functions which are deprecated in recent versions of PHP and recent versions of PHP also complain about calling class method statically if it isn't marked as a static function. If PHP is configured to ignore these warnings, then ProcessMaker should function correctly.

In your php.ini file, add the following setting:

Code: Select all

error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

Then restart Apache or reboot for the new setting to take effect. If your php.ini file already has this setting, then perhaps you have two installations of PHP in your server and the other copy of PHP is being used.
Amos B. Batto ♦ ProcessMaker Technical Documentation Writer & Forum Manager ♦ Cofounder of ILLA-A

eventoteam
Posts: 8
Joined: Wed May 17, 2017 1:39 pm
Country: Pakistan

Re: Configuring and Installation

Unread postby eventoteam » Sat Jul 01, 2017 4:21 am

Currently we are Using PM Version 1.2.

I need to make changes in PM's php or WAMP php folder?

amosbatto
Posts: 5018
Joined: Mon Jun 22, 2009 10:28 am
Country: Bolivia
Location: La Paz

Re: Configuring and Installation

Unread postby amosbatto » Mon Jul 03, 2017 8:54 pm

You need to set this in the php.ini file for the PHP used by ProcessMaker.
Amos B. Batto ♦ ProcessMaker Technical Documentation Writer & Forum Manager ♦ Cofounder of ILLA-A

eventoteam
Posts: 8
Joined: Wed May 17, 2017 1:39 pm
Country: Pakistan

Re: Configuring and Installation

Unread postby eventoteam » Thu Jul 06, 2017 1:07 pm

Thankyou for your help.
I did this and wrote following lines of Code in sysGeneric.php

ini_set('display_errors', '0'); # don't show any errors...
ini_set('error_reporting', E_ALL | E_STRICT);

And it resolved all the issues.


Return to “Installation & Configuration”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest