Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

By Zeezo123
#787350
Hi there ProcessMaker, sorry for making this thread twice. Not sure where to put it.

I have PM 2.5.1 running. The System (PM's) timezone is set to America/Chicago, and so is the session_time_zone in MySQL. When I create a Case, the correct date/time is input into the application table in MySQL, but I can't for the life of me figure out why the PM GUI insists on displaying the computer's SYSTEM time. I do not want to have to change the SYSTEM_TIME_ZONE variable in MySQL.

Thanks for any help.
#787352
Edit your php.ini file on the machine where ProcessMaker is installed and change its date.timezone. See: http://php.net/manual/en/timezones.php
Then restart Apache for the new settings to take effect. Then, edit your env.ini file and set its time zone.
#787388
I've done this and the problem persists. It does not occur in version 3.1.

APPLICATION.APP_UPDATE_DATE contains the correct date modified, but APP_CACHE_VIEW.APP_UPDATE_DATE insists on being populated with whatever date SYSTEM is.
#787389
I know that the PM developers have been changing how PM handles time in recent versions, so I assume this is one of the things that they fixed. You might be able to hunt through the source code and find the line which sets that datetime. Otherwise, there is no fix except to upgrade or change the system time on your server.
Can I connect to firebird database?

If you want to connect the database remotely using[…]

Task with multiple users

Well i have worked for days on this project and th[…]

Multilple Flow Possibility

Hi Is it possible to have multiple flow in a sing[…]

Hi, Please tell to processmaker team for tran[…]