Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderators: ArturoRobles, ArturoRobles

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
By Maldayne
#826790
Hi all.

I have developed a process on my test machine and have exported it and imported it to a live machine. This worked perfectly with no issues. The process itself has no issues and runs as expected.
I made since made some live changes and then after receiving a request I wanted to export the process from the live machine back to my test environment and it wouldn't work.

If I try to export directly from the Designer tab I just get a infinite loading screen :
Capture.PNG
Capture.PNG (2.38 KiB) Viewed 1609 times
If I enter the process directly and try to export it I get an error :
Capture1.PNG
Capture1.PNG (58 KiB) Viewed 1609 times
I have added the full error text below :
(298.43 KiB) Downloaded 89 times
I cant attach the process here either since I can't export it to start off.
The ProcessMaker versions where installed with the exact same script and are both using the same version :
Capture2.PNG
Capture2.PNG (55.54 KiB) Viewed 1609 times
Does anyone know how to fix this issue?

Thank you in advance.
By Maldayne
#826795
Hi, Thanks for replying.

I read some posts mentioning that and the only special characters I had in the name was brackets so I removed them so the name looks like this :
Capture3.PNG
Capture3.PNG (6.14 KiB) Viewed 1579 times
I still receive the same error unfortunately.
By Maldayne
#826796
I found something else, when I go to :
settings -> Case List Cache Builder

I get this error:
Capture4.PNG
Capture4.PNG (54.82 KiB) Viewed 1572 times
in case the image quality is bad it reads:
"ERROR: [wrapped: No driver has been registered to handle connection type: ]"

And if I try to run it I get the following error:
Capture5.PNG
Capture5.PNG (6.42 KiB) Viewed 1572 times
The log file shows this (Password has been replaces but the values [email protected]# is used in the actual password):
Code: Select all
[2019-10-16 12:48:29] production.ERROR: PDOException: SQLSTATE[HY000] [1130] Hos                                                                                                                             t '192.168.0.82' is not allowed to connect to this MySQL server in /usr/local/pr                                                                                                                             ocessmaker/vendor/laravel/framework/src/Illuminate/Database/Connectors/Connector                                                                                                                             .php:68
Stack trace:
#0 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/Connector.php(68): PDO->__construct('mysql:host=192....', 'root', 'Test12                                                                                                                             [email protected]#', Array)
#1 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/Connector.php(44): Illuminate\Database\Connectors\Connector->createPdoCon                                                                                                                             nection('mysql:host=192....', 'root', '[email protected]#', Array)
#2 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/MySqlConnector.php(24): Illuminate\Database\Connectors\Connector->createC                                                                                                                             onnection('mysql:host=192....', Array, Array)
#3 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/ConnectionFactory.php(183): Illuminate\Database\Connectors\MySqlConnector                                                                                                                             ->connect(Array)
#4 [internal function]: Illuminate\Database\Connectors\ConnectionFactory->Illumi                                                                                                                             nate\Database\Connectors\{closure}()
#5 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ection.php(883): call_user_func(Object(Closure))
#6 /usr/local/processmaker/workflow/engine/controllers/InstallerModule.php(176):                                                                                                                              Illuminate\Database\Connection->getPdo()
#7 /usr/local/processmaker/workflow/engine/classes/Net.php(230): InstallerModule                                                                                                                             ::setNewConnection('NET', '192.168.0.82', 'root', '[email protected]#', '', 3306)
#8 /usr/local/processmaker/workflow/engine/methods/setup/appCacheViewAjax.php(37                                                                                                                             ): Net->tryConnectServer('mysql')
#9 /usr/local/processmaker/workflow/engine/methods/setup/appCacheViewAjax.php(28                                                                                                                             6): testConnection('mysql', '192.168.0.82', 'root', '[email protected]#', 3306)
#10 /usr/local/processmaker/workflow/public_html/sysGeneric.php(1067): require_o                                                                                                                             nce('/usr/local/proc...')
#11 /usr/local/processmaker/workflow/public_html/app.php(45): include('/usr/loca                                                                                                                             l/proc...')
#12 {main}
[2019-10-16 12:48:35] production.ERROR: PDOException: SQLSTATE[HY000] [1130] Hos                                                                                                                             t '192.168.0.82' is not allowed to connect to this MySQL server in /usr/local/pr                                                                                                                             ocessmaker/vendor/laravel/framework/src/Illuminate/Database/Connectors/Connector                                                                                                                             .php:68
Stack trace:
#0 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/Connector.php(68): PDO->__construct('mysql:host=192....', 'root', 'Test12                                                                                                                             [email protected]#', Array)
#1 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/Connector.php(44): Illuminate\Database\Connectors\Connector->createPdoCon                                                                                                                             nection('mysql:host=192....', 'root', '[email protected]#', Array)
#2 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/MySqlConnector.php(24): Illuminate\Database\Connectors\Connector->createC                                                                                                                             onnection('mysql:host=192....', Array, Array)
#3 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ectors/ConnectionFactory.php(183): Illuminate\Database\Connectors\MySqlConnector                                                                                                                             ->connect(Array)
#4 [internal function]: Illuminate\Database\Connectors\ConnectionFactory->Illumi                                                                                                                             nate\Database\Connectors\{closure}()
#5 /usr/local/processmaker/vendor/laravel/framework/src/Illuminate/Database/Conn                                                                                                                             ection.php(883): call_user_func(Object(Closure))
#6 /usr/local/processmaker/workflow/engine/controllers/InstallerModule.php(176):                                                                                                                              Illuminate\Database\Connection->getPdo()
#7 /usr/local/processmaker/workflow/engine/classes/Net.php(230): InstallerModule                                                                                                                             ::setNewConnection('NET', '192.168.0.82', 'root', '[email protected]#', '', 3306)
#8 /usr/local/processmaker/workflow/engine/methods/setup/appCacheViewAjax.php(37                                                                                                                             ): Net->tryConnectServer('mysql')
#9 /usr/local/processmaker/workflow/engine/methods/setup/appCacheViewAjax.php(28                                                                                                                             6): testConnection('mysql', '192.168.0.82', 'root', '[email protected]#', 3306)
#10 /usr/local/processmaker/workflow/public_html/sysGeneric.php(1067): require_o                                                                                                                             nce('/usr/local/proc...')
#11 /usr/local/processmaker/workflow/public_html/app.php(45): include('/usr/loca                                                                                                                             l/proc...')
#12 {main}

I have no idea why this is happening as this isn't happening in any of my test systems :cry:
Timeout Not Sending Email

I am confused, but I have setup a self-service as[…]

Hello; In a dynaform (for example: called "Gr[…]

issue with processmaker 3.2

Ok thank you but i have more questions For exam[…]

No, there's nothing wrong in the browser network a[…]