Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
By sgkalluri
Hello there,

We are using PM Enterprise version 3.3.13 on CentOS 7.6.

In our attempt to enable ssl traffic on PM we are facing a problem with WSDL services.

WSDL services works fine when there is no ssl. However, it shows the below error as soon as ssl is enabled. Any idea how this can be solved?

Error is...

SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://<server-name>/sysworkflow/en/neoclassic/services/wsdl2' : failed to load external entity "https://<server-name>/sysworkflow/en/neoclassic/services/wsdl2

This problem is experienced even in our previous version of PM 3.2.1.

The remaining part of PM seems to be working fine in ssl.

Many thanks in advance,
By ajcosta
Hi Satya,

I had same problem awhile back and resolved by removing from /etc/hosts my serverName.domain entry from it.

Hope it helps.

User avatar
By amosbatto
Satya, Was your /etc/hosts file or your DNS the problem?
By sgkalluri
Thanks AJ and Amos,

i don't know how to answer Amos' question. I am not that technically qualified. However, I thought of sharing the content's of our server's /etc/hosts file. It goes like this... localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

Would these contents cause the issue that we are facing?

Best wishes,
User avatar
By amosbatto
Satya, What happens if you create an empty /etc/hosts file?
By sgkalluri
Well, this does not work too. The same error pops up.

There could be something else. Maybe the way the SSL certificate is created. The SSL certificate that I am using is issue by an internal Windows Server. And, this certificate is accepted by the browser when we use PM in our internal company network.

I created another instance of PM outside our company network. I used a Letsencrypt certificate. I see that WSDL works fine there. I'll do some more tests to confirm that.

Will keep you updated...

Best wishes,
Satya Gopal
By sgkalluri
Hello everyone,

Looks like the problem is getting resolved.

I read a stackoverflow article ... ks-on-wamp and the solution given by gogagubi seems to work for me.

Looks like one has to change the ssl settings while creating a new SOAP client to allow 'invalid' ssl certificates.
Code: Select all
$options = array(
    'cache_wsdl' => 0,
    'trace' => 1,
	'stream_context' => stream_context_create(array(
          'ssl' => array(
               'verify_peer' => false,
                'verify_peer_name' => false,
                'allow_self_signed' => true

$client = new SoapClient(<wsdl url to be entered here>, $options);
I'll be doing some more testing and report back the results in a few days.

Best wishes,
Satya Gopal
Task doesnt have any users.

The first problem is that you need to use = = in[…]

Just guide me to implement this?

Hi, I have a text control (rfq_segment) and I wan[…]

Genial!!! gracias. :D i need to translate an[…]