Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
By HeshanKaru1994
#824501
/api/1.0/workflow/department/3720151675cda17ec8623c9018653231/assigned-user` resulted in a `400 Bad Request` response:\n{\"error\":{\"code\":400,\"message\":\"Bad Request: The user with \\\"7687140835c5815fe3e6c40046197367\\\" not have permissions to (truncated...)\n"
User avatar
By amosbatto
#824515
You need to provide more information and right click on the error to copy the entire error message. What are you trying to do?
By HeshanKaru1994
#824531
Hi,
I was using "GET /api/1.0/{workspace}/department/{dep_uid}/assigned-user" REST api to get assigned users of a selected department.And I got an error

`400 Bad Request` response:\n{\"error\":{\"code\":400,\"message\":\"Bad Request: The user with \\\"7687140835c5815fe3e6c40046197367\\\" not have permissions to (truncated...)\n

I was using pmConnector plugin for the purpose and was referring Lab:Processmaker Connectors in university.processmaker course
User avatar
By amosbatto
#824544
The user who executes that REST endpoint needs to have the PM_USERS permission in his role. Try executing that endpoint with the "admin" user.
View Dynaform in HTML Page

You might also want to check the [url=https://wiki[…]

You are going to have to put the configuration in […]

Hola, hay alguna forma de hacer que estos log se […]

Yo trabajo con la versión PM 3.2.3 - Ente[…]