Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
User avatar
By ebryant
#823781
Could someone tell me why I'm getting the below error message when I attempt to upload a document on a web entry page?
Attachments
Upload_Error.JPG
Upload_Error.JPG (22.26 KiB) Viewed 256 times
User avatar
By amosbatto
#823786
What version of PM? Do you mind posting the .json file for your Dynaform?
User avatar
By ebryant
#823810
Apologies on the double post as I initially posted in the wrong version board.

We're using version 3 and attached is the .json file.
Attachments
(70.85 KiB) Downloaded 13 times
User avatar
By amosbatto
#823815
Go to Admin > System Information to find your exact version of ProcessMaker.

MultipleFiles fields don't work correctly before version 3.2.2 in web entry. If you are using an older version of PM, then you need to use a File field. If you want the ability to upload multiple files, then you need to create a grid which has a file field in it, so the user can add multiple rows with File fields.
User avatar
By ebryant
#823971
Thanks for the response.

I'm using 3.3.5+Patch1+Cloud - Enterprise Edition.

By me using this version, which is higher than the 3.2.2 which you were referencing does that mean I should be able to upload multiple fields or should I just go with a File field
User avatar
By amosbatto
#823996
If you are using 3.3.5, then you should use MultipleFile fields. File files have problems in 3.2.2 and later in web entry.
".education" domain not supported

Worked like a charm.. I had no idea where this reg[…]

Wow, Thanks amazing to hear about it. :P I'm real[…]

Many Thanks :lol:

Thanks a lot. I'm not using that charts plugin. An[…]