Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderators: ArturoRobles, ArturoRobles

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
By stevensi1018
I have these errors when I click on 'Next step' from a Dynaform called 'Present' to another called 'Update'. I don't have any trigger and I can't see the XML file related to the Dynaform 'Present' in my files... I tried to import this dynaform from another process and I also tried to recreate the SAME dynaform in my current process and i still have the same errors. Any idea what this could be ?

"Warning: filemtime(): stat failed for /opt/processmaker/shared/sites/workflow/xmlForms/8914178875942c430b22383068174931/448242320598a1d478ee316076113849.xml in /opt/processmaker/gulliver/system/class.xmlform.php on line 5521"

"failed to open Xmlform File : No such file or directory in /opt/processmaker/shared/sites/workflow/xmlForms/8914178875942c430b22383068174931/448242320598a1d478ee316076113849.xml"

I also can't create any Dynaform from the interface. It creates it after showing this error message:
dynaform.PNG (10.93 KiB) Viewed 2346 times
User avatar
By amosbatto
First of all, does the file /opt/processmaker/shared/sites/workflow/xmlForms/8914178875942c430b22383068174931/448242320598a1d478ee316076113849.xml exist on your ProcessMaker server? If it exists, is the owner of the file "apache" if using Red Hat/CentOS or "www-data" if using Debian/Ubuntu and does that user have write access to the file? Does that user have write access to the /opt/processmaker/shared/sites/workflow/xmlForms/8914178875942c430b22383068174931 directory?

To avoid any issues with file permissions, you can change the file owner and permissions:
cd /opt/processmaker
chmod -R 770 shared
cd workflow/engine/
chmod -R 770 config content/languages plugins xmlform js/labels

Finally, change the owner of the ProcessMaker files to the user who runs Apache. This user depends upon your distribution:

chown -R www-data:www-data /opt/processmaker

chown -R apache:apache /opt/processmaker

chown -R wwwrun:www /opt/processmaker
By TarekEladly
Hi all,

I know that this is an old post but anyway I will put it as a record if amosbatto answer doesn't help.

Some times when you import the Processmaker don't create the files right if you browse to the folder and don't find the file do the following steps to solve the problem:-

    Copy any file in the folder.
    Rename the file to be the same as the missing one.
    Edit the file and remove the old ID and add the new ID ( the file name ).
    Save the file.

Run the process and cross your fingers to make it work :D

Tested on windows and working With ProcessMaker 3.3.3.

By edumen
I had same issue after importing a process, xml file was not created, TarekEladly's solution worked! :)
for ProcessMaker 3.3.6

I am so happy that I found[…]

Hi, Is there any method, e.g. by trigger, during […]

Hi, Please check the following link: http://pmle[…]

Where is processmaker-3.5.x.tar.gz ?

Hi, Please check this link:[…]