Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.

In previous versions of the Smartprocess application for Android it was possible to use the Chrome Remote Debugging Feature ( ... g/webviews) to test and debug our processes when running inside the mobile app.

But with the latest version of the application we're not able to do this any more. Is it only happening to me? How can we debug our processes when running inside the app without this feature? Because sometimes you see strange behaviors that only occur in the mobile app, not in the browser.

Thanks for your help.

Hi Amos,

We are still using Processmaker version 3.1.2 Enterprise Edition. Regarding the mobile app, its the version.

Our mobile device has Android 4.4.4

Chrome Remote Debugging feature worked perfectly in the same device with previous versions of the mobile application.

Thanks for your help.

I just tried debugging and it works with ProcessMaker Mobile App in Android 6, connected to ProcessMaker 3.1.2 Enterprise, using Chrome 50 in Debian Linux and it works. You should upgrade the mobile app to and see if that fixes it.
debugAndroidPM3.1.2.png (212.08 KiB) Viewed 3110 times
Hi Ammos,

I have updated the application to the last version, as you mentioned, and tested in two different devices (one with Android 4.4.4 and other with Android 5).

My browser recognizes them in the chrome://inspect tab, and if I open a normal tab in the chrome browser I can inspect it. But when I open a form in the mobile application it does not show anything.
If I use version of the application, it allows me to debug remotely our Dynaforms.

Any idea? Maybe its a windows problem or something?

Thanks for your help.


As you have got seen that after every single updat[…]

issue with processmaker 3.2

Hello! The solution to your question is the foll[…]

BPMN project disappeared

Hi Alex! , maybe you forgot to save your process[…]

mcrypt extension is deprecated!

Hello Ehsan! If you did not find the mcrypt ext[…]