Questions and discussion about developing processes and programming in PHP, JavaScript, web services & REST API.

Moderator: amosbatto

Forum rules: Please search to see if a question has already asked before creating a new topic. Please don't post the same question in multiple forums.
#826466
Hello Amos,

I am trying to execute a trigger using the Webservice and the executeTrigger function.
I am using the webservice, because I would like to execute a trigger within a different case.
This does not work and I get back an error message from the function : "The row ', 2' in table AppDelegation doesn't exist!"

As this didn't work, I have simplified the challenge and I have set up a test-process, in which I am trying to do this
within the current case (to make it a bit easier).

After task1 (after routing) a trigger is fired named "execute Trigger using Webservice" which should execute another trigger
named "triggerToBeExecuted". This trigger just sets the dynaform variable "checkTriggerExecution" to "success: trigger has been excecuted".

After the trigger has been fired (after routing), again the following error message is given back from the function:
"The row ', 2' in table AppDelegation doesn't exist!"

Interestingly it says ', 2' does not exist --> it states a comma! Of course there is not an entry in the APP_DELEGATION table
having DEL_INDEX = ', 2'

We are using 3.3.2-community edition release/3.3.2.c1f6571.

Could you please have a look for me?

Thank you for your support.

Kind Regards,

Oliver
Attachments
(35.21 KiB) Downloaded 2 times
#826515
Oliver,
The problem is that the Dev team decided to remove the ability to login to web services using the hashed password because they deemed it a security threat, and it looks like the Documentation team wasn't informed, so the wiki is out-of-date.

Here is what you need to do:
Code: Select all
$ws = new WsBase();  
$ret = $ws->executeTrigger($userId, $caseId, $triggerId, $delIndex) 
For more info, see the code in workflow/engine/classes/WsBase.php
Task doesnt have any users.

I have created a small process. Users are assigned[…]

NEW MOBILE APP ISSUE

Just trying to setup to use the mobile App with my[…]

It's really a great idea. I have followed the seco[…]

yes i use php thanks for the information