Questions and discussion about using ProcessMaker: user interface, running cases & functionality
#828887
Processmaker ver 3.5.7.
After creating reporting table - new cases are struck in draft mode and routing to next task is not happening. Following error in log.
production ERROR: [wrapped: Could not execute query [Native Error: Unknown column 'PMT_PMS_EDIT_STATUS.FHEMPNO' in 'field list'

The referenced field FHEMPNO is part of the process, but not added into the report table. Only deleting the report table will solve this issue and we must restart the queues (laravel processes) so that ones struck in the queue are released.
Recreating the report table again - the issue is not there, everything works fine. This has happened with few reporting tables across a couple of processes so far since we installed three weeks before.
Not sure if anyone else has faced this.
Thanks
#829715
Hi survia,

same problem here, with same PM version.
Happens systematically when you edit a column name of a Report Table or when you delete a column. Re-adding the column or renaming it back to its original name does not solve the problem.
Deleting and re-creating the table with the same name does NOT solve the problem. It seems that PM keeps some state of the edited PM tables.
The only solution is to delete the report table and create a new one with a different name.

This bug is really unforgiving, i.e. you cannot fix it if you make errors in the report table definition.
Also it forces you to be very selective with the columns you add to a report table. You will never be able to remove them.

Help would be appreciated

Roberto
#829876
Hello Survia,

Please try restarting the supervisord service:

service supervisord restart

The problem here is that since PM 3.5 uses async mode for routing and for table generation, the job will grab a snapshot of the report table when it was created, so, even after editing it, it will still look o the initial snapshot, in this case, restarting the supervisord service will help, on the other hand, you could disable the async mode and make it sync, you add this line in the envñini file under [installation_path]/workflow/engine/config/env.ini
disable_task_manager_routing_async = 1

https://wiki.processmaker.com/3.5/Configuration_File_env.ini#Available_Settings

Unfortunately, this is only available from 3.5.8

Let me know if any of these suggestions worked.

Regards,
send birthday greeting

Hello alisoroush7, You need to query the USERS […]

ProcessMaker 3.6.5 Open Source

Hello Vysakh ProcessMaker 3.7.4 will be availab[…]

wifi signal blocker

This is a new rl=http://www.jammerall.com/categor[…]

cell phone jammer

url=http://www.jammerall.com/categories/Cell-Phon[…]