Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderators: ArturoRobles, ArturoRobles

By kcgiri
Hello there,

I have recently installed version 3.5.2 (through Bitnami).
Designed couple of processes - tasks, variables, DynaForms, users/groups, rule assignments, etc. as per the start guide in community. I am a non-tech designer and already loving the intuitiveness of the platform.

I had no problems until starting a case.
After the new case instance is run, and the first task's form is filled and submitted - the task completes and shows a window with "Next Task/Event" and "Next User" info. Till now, the case shows in Draft list.

However, upon hitting Continue at that point, the case disappears. When I log in as the relevant user, it is not in that user's inbox (even when assigned the start and following task to same user or default admin user).

The participant list shows an increment, but when I click on the button - it throws up an error message as below:
"An unexpected error occurred while searching for your results. Error Code 200 and Please contact your administrator."

The records in APP_DELEGATION and APP_CACHE_VIEW are getting updated with new cases (I have attached them here).

I faced this issue first on my own designed process. Then, I replicated the design of "Purchase Request" process with all elements exactly as per the Start Guide, and ran it - and I am facing the issue for that as well.

Please could you help with this ? I have installed through Bitnami on Windows 10 Pro x64 localhost.
Let me know if you need any other information related to this issue.


(4.06 KiB) Downloaded 27 times
(5.29 KiB) Downloaded 24 times
If you are using version 3.5 and above for route cases correctly, you must do the necessary configuration according to the following guide:

Also I made a video to help you solve participated error, you can watch it and solve your problem accordingly.
Please check the following video:
By kcgiri
Appreciate the response, programmerboy!

The participated error is resolved, thanks to your video. I can see the number of cases without error.

Regarding the route cases configuration, i was able to install the service using nssm.

But I was unable to start the service with both options.

1) Using command line... it gives me error "Can't open service! OpenService(): Access is denied."
2) From Windows Services Panel, it gives me the error "Windows could not start the service on Local Computer. This service did not return an error..." (screen shot of full error message attached).
I tried checking "allow service to interact with desktop" option for local system account, as well as changed login to "This account <my local user>", but the service still does not start.

I thought this could be a windows issue - tried various google search solutions, but unable to solve.

Also, I now see in the ProcessMaker Admin "Check PM requirements" that the Mcrypt Support is Not Enabled." I searched and found this solution in the forum"". I downloaded and tried both TS and NTS .dll files for my Windows x64 desktop. But Mcrypt support is still not showing as enabled.

Not sure whether the route case services issue and Mcrypt not enabled are related.

But appreciate any further help.

Thanks again.
ProcessMaker Jobs for workflow not starting.png
ProcessMaker Jobs for workflow not starting.png (5.49 KiB) Viewed 718 times
By kcgiri
attached a few more screenshots in support of my earlier response to your resolution....
Service path correctly entered and checked with file paths in installation details .
Windows Services Panel.png
Windows Services Panel.png (104.88 KiB) Viewed 718 times
NSSM Service Editor.png
NSSM Service Editor.png (6.63 KiB) Viewed 718 times
To confirm that except mcrypt extension, all other requirements are in place.
CheckPMRequirements.png (97.89 KiB) Viewed 718 times

By kcgiri
Sorry to jump in again, but the Mcrypt.dll issue has been resolved. PM requirements shows full green after restarting the desktop.

So, just the Route Cases service issue for now.

By kcgiri
Thanks programmerboy,

Had been using Powershell with admin...

tried with Admin CMD as well, but same result.

Getting error "processmaker-jobs-workflow: Unexpected status SERVICE_PAUSED in response to START control." Screenshot below:
AdminCMD_NSSM_Service_Error.png (146.09 KiB) Viewed 700 times
Maybe I am doing something else wrong.

Sorry to bother with trivial stuff, but am not a techie. So appreciate any help here :)


By kcgiri
I could start the service now.... my mistake in interpreting the file path instructions given by programerboy.

I had assumed the path to Processmaker folder was the first installation folder... but I found out that the artisan and processmaker files were in the htdocs folder under apps/processmaker/ which I then edited in the nssm service.

all pain but gain in the end. The process is flowing smoothly now.
Some small hiccups - like Submit buttons not working in the forms, but that's for another topic :)

Thanks programerboy... very helpful.

Hello everyone, I have the same route case issue, the user assignment is not working after submitting the first task. I could install the Supervisor in Linux according to the instructions, but it didn't solve the issue. What else should be done?
Install in ubuntu

Nov 8, 2014 — You can install applications d[…]

Hi, The form.setOnchange() method does NOT work w[…]


Hi, You can easily change your forms like this eve[…]

Dear All Please help me I have installed process[…]