Page 1 of 1

MSSQLConnection.php on line 367

Posted: Sat Apr 18, 2020 7:21 pm
by rguerra16
Hi,

I recently installed PM 3.4.9 to work on some integration concepts with BPM.
Its installed on RHEL 7.8 mySQL 5.7 and PHP7.3.17 using the instructions on stack N265 for nginx.

I got some trouble installing the mssql extensions but after solving a couple of broken relations i got it on. But now, when i open a Dynaform that has a query directly to the mssql database, i get this warning:
***Warning: count(): Parameter must be an array or an object that implements Countable in /opt/processmaker/thirdparty/creole/drivers/mssql/MSSQLConnection.php on line 367**

I tried searching on it here but no luck. Also on the internet, but seems something you can change on your code.
Hope someone has had solved this issue before :D

Re: MSSQLConnection.php on line 367

Posted: Wed Apr 29, 2020 4:18 pm
by RicardoMG
Hello

If the database connection was successful, then you can do the following in the php.ini so that you don't see these warnings:
error_reporting = E_ALL & ~E_WARNING & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED

Best regards, Ricardo

Re: MSSQLConnection.php on line 367

Posted: Wed Apr 29, 2020 5:32 pm
by rguerra16
Hi Ricardo,

Thanks for your reply.
After submitting this ticket i did that and didn´t work. I copied exactly the same line that you have and still.
Eventhough we have this line, the display_errors value is set to off. So it should be reporting anything, right?

Any other file that might have this configuration?

Regards.

Re: MSSQLConnection.php on line 367

Posted: Thu Apr 30, 2020 5:23 pm
by RicardoMG
Hello!

So that it takes the changes the php.ini file, you need to restart the nginx service.
Do You restart the nginx service?

Well, in the line of code that I passed to you, it will disable the warnings and notifications that php can launch when using processmaker

Best regards, Ricardo.

Re: MSSQLConnection.php on line 367

Posted: Thu Apr 30, 2020 5:36 pm
by rguerra16
Hi Ricardo,

Thanks for your reply. Yes, i did restart nginx and php services.
Weird, because the error display is off, so it shouldn´t be displaying anything. I also found that probably in the .conf file for processmaker, you could enter something similar for error displays. I did that too and didn´t work.

Clean the cache and open it on another browser in case it was that, but still same result. Any other idea?
Regards,

Re: MSSQLConnection.php on line 367

Posted: Thu Jun 25, 2020 12:12 pm
by programerboy
Hi,
Please set a simple password to your sqlserver database and check again.

Please check the following link:
http://pmlearning.info