Page 1 of 1

ERROR IMPORTING 2.5 PROCESS in 3.4.7 Community

Posted: Wed Feb 19, 2020 7:50 am
by as13969
Dear All,

We have a fresh install of PM community 3.4.7. I tried to import one of the process created in PM 2.5 community and below is the error messages displayed. Attached is the process I'm trying to import.

ErrorMessage.JPG
ErrorMessage.JPG (72.84 KiB) Viewed 8332 times
Could you please advise what steps to troubleshoot this issue?

Thanks, in advance.

Alfred

Re: ERROR IMPORTING 2.5 PROCESS in 3.4.7 Community

Posted: Wed Feb 19, 2020 12:47 pm
by dan123dan
Hi,

Please set the display_errors = Off in your env.ini file

Go to "/opt/processmaker/workflow/engine/config/env.ini" and at the end of the file add 'display_errors = Off'

Let me know if this helps you.

Re: ERROR IMPORTING 2.5 PROCESS in 3.4.7 Community

Posted: Fri Feb 21, 2020 3:11 am
by as13969
Hi dan123dan,

Thank you for the reply and providing the workaround for the import error.As instructed, I've modified the env.ini file and added the display_errors = Off but still displaying one error. In addition, dynaforms and trigger functions are not displaying only the process flow.

Please advise if anyone encounter this issue when importing a process from 2.5 (commnity version) to a fresh install of PM 3.4.7 (community version)
PM 3.4.7_ImportError1.JPG
PM 3.4.7_ImportError1.JPG (28.67 KiB) Viewed 8298 times
Unable to execute INSERT statement. [wrapped: Could not execute update [Native Error: Column 'DYN_VERSION' cannot be null] [User Info: INSERT INTO DYNAFORM (`DYN_ID`,`DYN_UID`,`DYN_TITLE`,`DYN_DESCRIPTION`,`PRO_UID`,`DYN_TYPE`,`DYN_FILENAME`,`DYN_CONTENT`,`DYN_LABEL`,`DYN_VERSION`,`DYN_UPDATE_DATE`) VALUES (NULL,'221313476561d152d5abaf9082040370','gridCatering','','42907714855fab8584099550139

Thanks , in advance.

Alfred

Re: ERROR IMPORTING 2.5 PROCESS in 3.4.7 Community

Posted: Sun Feb 23, 2020 11:06 am
by programerboy
Hi,

In the structure of table DYNAFORM change the DYN_VERSION column and check the null option and save table changes.
Then try again.


https://www.youtube.com/channel/UCYiyz1y8Qf4EZjMXodwH1iw/videos
https://www.linkedin.com/in/pmlearning/
Thanks

Re: ERROR IMPORTING 2.5 PROCESS in 3.4.7 Community

Posted: Mon Feb 24, 2020 7:33 am
by as13969
Hi programerboy,

Thank you for the email and solution for this issue. :)

After setting the DYN_VERSION column value to allow NULL I was able to import the 2.5 process to 3.4 PM community version.

Alfred