Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderator: amosbatto

By igrcyt
#817194
Hello processmaker community,

I've been trying to upload large files (made some tests with 80Mb files) but can't get it done. No error displayed, no error on apache log, the green fileuploader progressbar is at 100% and seems OK... but the file is not on "C:\Bitnami\processmaker-3.2.1-0\apps\processmaker\htdocs\shared\sites\workflow\files\........."

Of course i've set the properties on InputDocument to no size limit, also in the fileupload control.
In the php.ini file i got:

upload_max_filesize = 500M
post_max_size = 600M
max_execution_time = 300
max_input_time = 300
memory_limit = 512M

What's wrong? what did i miss?

Thanks in advance :)
By igrcyt
#817203
Checking Php Info page found something strange:

upload_max_filesize master is the limit i set, but local value is 20M. Where is the setting being overriden?
By igrcyt
#817375
Found IT!!!

ON: https://wiki.processmaker.com/3.0/Addit ... _Documents
Bitnami (Windows):

C:\Bitnami\processmaker-3.X.X.X.bX-0\php\php.ini
C:\Bitnami\processmaker-3.X.X.X.bX-0\apps\processmaker\conf\httpd-app.conf
Note: Bitnami installations of ProcessMaker add the following PHP settings in the apps/processmaker/conf/httpd-app.conf file, which overwrite the settings in the php.ini file:

<IfModule php5_module>
php_value short_open_tag On
php_value memory_limit 512M
php_value upload_max_filesize 100M
php_value max_input_vars 8000
</IfModule>
Make sure to edit this file, if needing to change one of these PHP settings.

Hello everyone in previous versions of PM the ca[…]

Buen día, a todos Hace un par de día[…]

Perfecto amigo muchas gracias.

hello to all, please your help to resolve this dou[…]