Questions and discussion about using ProcessMaker: user interface, running cases & functionality

Moderator: amosbatto

#784610
Hi

I grabbed the latest from bitnami (old is also from bitnami). Imported a process and found I cant enter a new case (users have permissions to create cases). Tried with different user groups as well as standard and mobile UX.

Fatal error: Call to undefined method PMLicensedFeatures::verifyfeature() in /opt/bitnami/apps/processmaker/htdocs/workflow/engine/classes/class.pmDynaform.php on line 379

Any ideas what's going wrong?
Thanks
Andrew
#784612
Hi Rundyz

That linked thread is talking about v2 to v3 it seems. I have gone from 3.0.1.5 to 3.0.1.7. I'll try commenting out and see what happens.

Interesting, the section of code is below, line 379 is the if statement in the middle. Seems there is something funny with licensing, from the change list it seems that there is new features with licensing so this could be a bug from the change.
Code: Select all
                if ($key === "type" && ($value === "file") && isset($this->fields["APP_DATA"]["APPLICATION"])) {
                    /*----------------------------------********---------------------------------*/
                    $licensedFeatures = &PMLicensedFeatures::getSingleton();
                    $enablePMGmail = false;
                    if ($licensedFeatures->verifyfeature('7qhYmF1eDJWcEdwcUZpT0k4S0xTRStvdz09')) {
                        G::LoadClass("pmDrive");
                        $pmDrive = new PMDrive();
                        $enablePMGmail = $pmDrive->getStatusService();
                    }
#784613
OK, commented out the function and could then enter the first form, but then after submitting it I get this error:
Fatal error: Call to undefined method PMLicensedFeatures::verifyfeature() in /opt/bitnami/apps/processmaker/htdocs/workflow/engine/methods/cases/cases_SaveData.php on line 365

Which also happens to be the line: if ($licensedFeatures->verifyfeature('7qhYmF1eDJWcEdwcUZpT0k4S0xTRStvdz09')) {
#784614
Having the same problem, but with workflow/engine/methods/cases/cases_SaveData.php

Temporary workaround hack, add the following code to workflow/engine/classes/class.licensedFeatures.php, just before the last ending brace }
Code: Select all
    public static function verifyfeature()
    {
        return true;
    }
#784615
Hello all,

Please make sure, as it's stated in the Release Notes for version 3.0.1.7: https://docs.google.com/document/d/1FjZ ... dOCiyY/pub, to have PHP 5.4 installed before upgrading to or performing a new installation of ProcessMaker 3.0.1.7.

We advice against modifying the source code, since all changes will probably be lost after an upgrade to a later version.


Best regards,
#784616
Hi Arturo

PHP version is 5.4.45. I'm using the Bitnami VM from here: https://bitnami.com/stack/processmaker/virtual-machine

If I create a new process I can run a case correctly, seems its to do with importing the case that was created entirely in 3.0.1.5.

From the Check PM Requirements section:
PHP Version >= 5.2.10: 5.4.45
MySQL Support: Client API version mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $
cURL Version:
cURL 7.45.0
OpenSSL Version (*): OpenSSL/1.0.1p
DOM/XML Support: Enabled
GD Support: bundled (2.1.0 compatible)
Multibyte Strings Support: Enabled
Soap Support: Enabled
Mcrypt Support: Enabled
LDAP Support (*): Enabled
Memory Limit >= 80M: 256M
#784619
I have a similar issue after my upgrade from 3.0.0.3 to 3.0.1 to 3.0.1.7. When submitting a case which contains a file upload grid form I get the following error.

Fatal error: Call to undefined method PMLicensedFeatures::verifyfeature() in /opt/processmaker/workflow/engine/methods/cases/cases_SaveData.php on line 365

Also, when I got to the Documents view, I can see all the folders in the documents list, but none of the documents that have been submitted in cases are listed any more. I have confirmed the files are still located in /opt/processmaker/shared/sites/<workspace> but for some reason it isn't picking them up. It also won't let me add new files through the Documents view. No error message when trying, just doesn't do anything when clicking upload.

ProcessMaker Version 3.0.1.7-community
System CentOS release 6.7 (Final) (Linux)
PHP Version 5.4.45
Plugins charts
openFlash
pmosCommunity
processTemplate
MySql Version MySql (Version 5.5.46)


This is a big problem for me right now, and considering restoring a pre-upgrade backup.
#786024
I have the same issue and wondering if I should apply the temporary fix outlined above or wait until a proper fix has been made available. Is this a known issue? Arturo talked about upgrading PHP but my version is later than this already as well. I'm not sure what the problem is but it seems to happen only with generating output documents for me at least.
#786040
I have filed a bug report about this issue. See:
http://bugs.processmaker.com/view.php?id=20825

Please add your comments about this problem in the bug report, so the PM developers will see them. (They do not read the forum.) Also, please attach any processes which are causing problems to the bug report.
#825461
I grepped the code and can only find "createCaseFolder" in the charts plugin, which is defined in workflow/engine/plugins/charts.php.
Are you using the charts plugin?
#825476
Thanks a lot. I'm not using that charts plugin. And sometimes I spend to find the issue.

Fixed by the following steps
I have imported the sample plugin
The mistake I have done as I have removed the plugin from the source path manually
We i debug the the plugin name was in the session. The code checks for the plugin. Unfortunately, the plugin was not on the path so that I got an issue
Then I have imported the sample plugin and deleted by the button in Settings -> plugins -> Delete

Finally, it works well

@{ var result = ""; if (IsPost) […]

Hi, Could you explain to me what is the differenc[…]

Routing Logic

Thanks Amos, will do it how u recommended.

Did you set up your ProcessMaker server to periodi[…]