Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

#825058
Hi guys,
Im using process maker 3.3.6-1 community edition on my local windows 10 pc.
Based on documentation at here :https://wiki.processmaker.com/3.3/Datab ... ions/MSSQL ,\
You said we should download the php_dblib.dll file for our system's architecture and PHP version. Since the version of my PHP is 7.1.27 , I search for the dll file you said .But i cant find the php_dblib.dll fo PHP version 7.1 because it had been deprecated at version 5.6.
This is a note from php.net which emphasis this point :

PDO_DBLIB is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Microsoft SQL Server and Sybase databases through the FreeTDS library.
This extension is not available anymore on Windows with PHP 5.3 or later.

So what i must to do ?
please notice that i tried your instruction with the dll you provided for PHP version 5.6.x (I do all steps correctly) but after doing all the steps and also reset the Apache server, no option added to "Engine" combo box when i want to create a database connection.
please help me fixing this problem
Thanks in advance
#825110
You need to undo the changes that you made. Delete the following line from your php.ini file:
extension=php_dblib.dll

In PHP's \ext\ directory, do you see two files named php_sqlsrv.dll and php_pdo_sqlsrv.dll? If so, then you edit your php.ini file and add the lines:
Code: Select all
extension=php_sqlsrv.dll
extension=php_pdo_sqlsrv.dll
Then reboot (or restart Apache).

If you don't see those files, then you will have to install PECL. You can follow these instructions to install PECL:
https://link.springer.com/content/pdf/b ... -8%2F1.pdf

Then, use the "cd" command to navigate to the directory where PHP is installed and issue these commands:
pecl install sqlsrv
pecl install pdo_sqlsrv
#825303
I follow all the instructions but at the final step when i execute pecl install sqlsrv , it cant download and install sqlsrv because of some ssl problem.
the full log :
Could not download from "https://pecl.php.net/get/sqlsrv-5.6.1.tgz", cannot download "pecl/sqlsrv" (Connection to `pecl.php.net:443' failed: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?)
Error: cannot download "pecl/sqlsrv"
Download failed
install failed
#825321
Are you using a manual install or a Bitnami installation? If you are using a Bitnami installation, then I'm afraid that you are probably going to have to do a manual install.
#825343
I used Bitnami installation but why ? does any thing missed from Bitnami installer which may be need for connection to sql server database ? anyway i dont have any problem by manual installation just tell me how to do this ?
thank you
#825363
You can't easily add PHP extensions to a Bitnami installation. You will need to do a manual installation. If you do a manual installation, it will probably already include the PHP extensions that you need. If it doesn't, then following my instructions above.

Hi, Is there any way to show my custom column only[…]

Send for clarification

Hi, I know this is an old post but i could not fin[…]

add dropdown to search process

Please replay if there is any solution!!!!

Amosbatto, PMUsers.com is down.

Hi Amos, I appreciate you setting up a tips and t[…]