Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By jdcrain

I'm having some issues installing the extrarest plugin for ProcessMaker. I downloaded the tar file from here: ... D.2Fupload and when I tried to import the plugin I got the following error:

Task does not have a routing rule. Please, check the process definition.

Current PM version is 3.3.9 - Enterprise Edition and is the Cloud solution.
By jdcrain
I only had it open in one tab, and I tried clearing the cache, closing all browsers, and switched to a new browser and I'm still getting the same error even with the new tar file. I also tried clearing the ProcessMaker cache to see if it would help any, but still no luck.

I deleted some existing cases to see if they might somehow be causing the error but that didn't seem to help any either.
User avatar
By amosbatto
I just installed PM 3.3.9 Enterprise and then imported the extraRest 1.12 plugin without any problems.

Are you going to Admin > Setup > Plugins Manager to import the plugin? (Do NOT go to Admin > Setup > Enterprise Manager.)

What is the address of your cloud installation?
User avatar
By amosbatto
Are you sure that you are downloading the .tar file correctly? Right click on the link and select Save Link As to download it. Maybe you have some firewall that is checking the files that you download and that is transforming the file.
The MD5 sum of the file is 5fa710ed3f78c6406e907ee1e59d9f30

In Linux, you can get the MD5 sum of the file with this command:
md5sum extraRest-1.12.tar

If you use Windows, see: ... le-4037391
By jdcrain
Well I'm not really sure what happened, but I came back after a few hours and the plugin looked like it was installed. I tested some of the endpoints after enabling the plugin and it looks like the plugin is working
User avatar
By mdbarber
I have exactly the same issue importing a custom plugin on PM 3.3.3

Has this issue been reported as a bug?

I guess I'll just a have to wait a few hours like jdcrain.
Task doesnt have any users.

I have created a small process. Users are assigned[…]


Just trying to setup to use the mobile App with my[…]

It's really a great idea. I have followed the seco[…]

yes i use php thanks for the information