Page 1 of 1

Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Thu Apr 25, 2019 7:27 pm
by amosbatto
If using ProcessMaker Community Edition, version 3.2.2 and later have the following critical bugs:

* Datetimes in logs use the UTC time zone in 3.2.2+
* Home > Participated doesn't work in 3.2.2+
* Options in the Information menu don't work in 3.3.0+

None of these problems exist in the Enterprise Edition, which receives a higher level of testing and quality assurance.

Here are instructions to fix the code in version 3.2.2 and later to work around these bugs:
https://www.pmusers.com/index.php/Bugs_ ... _upgrading

For now I don't recommend that anyone upgrade or install beyond version 3.2.1 Community, until these bugs get fixed. For people how have already installed/upgraded beyond 3.2.1 Community, apply the code fixes and please report any other problems that you encounter.

Sorry about the inconvenience,
Amos

Re: Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Fri Apr 26, 2019 6:02 am
by jemiris
Thanks for the information

Re: Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Mon May 27, 2019 4:17 am
by Nickvermeulen
Amos

Do you mean that we should not use 3.3.6 or is your warning just referring to 3.2 variants?

Thanks

Nick

Re: Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Mon May 27, 2019 3:12 pm
by amosbatto
Nickvermeulen wrote: Mon May 27, 2019 4:17 am Amos
Do you mean that we should not use 3.3.6 or is your warning just referring to 3.2 variants?
As of version 3.3.10, these bugs still haven't been fixed. You will have to change the source code to use 3.3.6 as explained in:
https://www.pmusers.com/index.php/Bugs_ ... _upgrading

Re: Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Sat Jul 20, 2019 12:22 am
by JamesFoulds
Detail information, thanks for your sharing.

Re: Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Mon Jul 29, 2019 3:17 pm
by dragontattoo
thanks for the detailed information

Re: Not recommended to install or upgrade higher than ProcessMaker 3.2.1 Community Edition

Posted: Tue Aug 06, 2019 6:23 am
by JackRyan404
Hey, I can see that the information posted here is highly detailed and useful, thank you so much.