Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By FouadSar
I work on PM 3.2.1 and there is a problem when the users try downloading documents and the error 403 appear, although the user are assigned to the task and have input and output document permission, the user is not able to download the attachment, so appreciate if anyone can help please.
By FouadSar
Thanks for your reply, I added the flag (disable_download_documents_session_validation = 1) to the env.ini located at C:\Bitnami\processmaker-3.2.1\apps\processmaker\htdocs\workflow\engine\config\env.ini but that did not solve the problem, in spite of all the users have a permission for viewing input and output document and assigned to the task but still get the same error.
User avatar
By amosbatto


Does it work now?
By FouadSar
the "env.ini" file does not exist in the following path: C:\Bitnami\processmaker-3.2.1-0\apps\processmaker\htdocs\shared\sites\workflow, I tried to copy it from the path "C:\Bitnami\processmaker-3.2.1-0\apps\processmaker\htdocs\workflow\engine\config" but also did not work, additional note as admin I am able to see and download the uploaded files in a task which is assigned to me from the document from Home --> main menu on the left --> Documents.
User avatar
By amosbatto
This is strange. Let's verify that ProcessMaker is reading the env.ini file correctly.

Import this process in your installation of ProcessMaker:
(35.86 KiB) Downloaded 23 times

Then, assign a user to the "Task 1" and run a case in the process.

It should display the system configuration and you should see:

Do you see that?

showSystemConfig.png (91.28 KiB) Viewed 959 times
By FouadSar
I applied it and found that value still 0 not 1 as attached. I restarted the server but did not solve the problem so could you please advise?
pm.PNG (80.4 KiB) Viewed 953 times
User avatar
By amosbatto
This is bizarre. Can you post the contents of both your workflow\engine\config\env.ini and shared\sites\workflow\env.ini files?

For now, edit your file workflow\engine\classes\class.system.php and change line 83 from:
Code: Select all
        'disable_download_documents_session_validation' => 0
Code: Select all
        'disable_download_documents_session_validation' => 1
Now, it should work but I don't understand why ProcessMaker isn't reading your env.ini file.
By FouadSar
I did not find the file you mentioned "workflow\engine\classes\class.system.php", inside engine I only have config folder. I also do not have env.ini file in "shared\sites\workflow\" as attached.
PM3.png (14.59 KiB) Viewed 937 times
PM2.png (11.45 KiB) Viewed 937 times
User avatar
By amosbatto
You are looking in the wrong place.

The path on your server should be something like:
By FouadSar
Hi, in the path you mentioned there is only one folder which is config as attached. I did not find classes\class.system.php anywhere.
PM4.png (6.35 KiB) Viewed 886 times
By FouadSar
Hi, it turned out that the installation folder for the working PM currently is not on the C drive, it is on the E drive, so after i added the disable_download_documents_session_validation=1 flag to the env.ini file in the correct path it has been solved. thanks a lot for your support.
generate daily excel report

I have exported table into excel sheet as shown in[…]

Please replay if there is any solution!!!!

Task doesnt have any users.

Amosbatto: One more thing if you can help me with.[…]

Just guide me to implement this?