Page 1 of 1

Migrating from 3.0.1.7 to 3.2.1 version

Posted: Tue Feb 26, 2019 2:05 am
by chanatsamon
Hi,

I'm sorry to post a new topic.
I would like to get advice from you again.

The current version I use is installed from ProcessMaker-3.0.1.7-community-Setup.exe
I want to move from 3.0.1.7 version to 3.2.1 version without losing any of the existing case data.
I tried many ways. But still not working.

Example
1. I follow this guide. https://wiki.processmaker.com/3.2/Upgra ... ocessMaker But I haven't upgraded the resources. It doesn't work, just the home page.
2. I follow this guide. https://www.pmusers.com/index.php/Migra ... al_install By Bitnami install 3.2.1 version. but ProcessMaker doesn't work.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Wed Feb 27, 2019 12:23 am
by amosbatto
chanatsamon wrote: 1. I follow this guide. https://wiki.processmaker.com/3.2/Upgra ... ocessMaker But I haven't upgraded the resources. It doesn't work, just the home page.
Those instructions are only for upgrading a manual installation of ProcessMaker. They won't work for your installation, because you used the old automatic installer.
chanatsamon wrote: 2. I follow this guide. https://www.pmusers.com/index.php/Migra ... al_install By Bitnami install 3.2.1 version. but ProcessMaker doesn't work.
These instructions are for Bitnami -> Manual. I haven't tried migrating from the old automatic installer to a manual install. Maybe it will work. Since you changed versions, you need to run the processmaker upgrade command.

In a terminal, try this:
cd C:\opt\processmaker
C:\php\bin\php.exe processmaker upgrade
(you will need to include the full path to the php.exe file or add it to the PATH system variable.)

Does that fix it?

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Wed Feb 27, 2019 12:49 am
by chanatsamon
Hi Amos,

Thanks for the explanation.
I should now migrate version 3.0.1.7 from the old automatic installer --> Manual installation.
And then migrate from 3.0.1.7 --> Manual installation 3.2.1 ??

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Wed Feb 27, 2019 1:24 am
by amosbatto
chanatsamon wrote:I should now migrate version 3.0.1.7 from the old automatic installer --> Manual installation.
And then migrate from 3.0.1.7 --> Manual installation 3.2.1 ??
Yes, that is the way to do it.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Sat Mar 23, 2019 8:00 am
by chanatsamon
Hi Amos,

Now migrating already done.
How to :
1.install manual 3.0.1.7
- MySQL 5.5.62 (64bit)
- Apache 2.4.38 VC11 (32bit)
- PHP 5.4.16 VC9 (32bit)
- processmaker-3.0.1.7-community.tar.gz
Follow this guide : https://wiki.processmaker.com/3.0/Windo ... stallation

2.Import the workspace database(s) from old automatic installer to a manual install.
Follow step 3 and step 4 this guide : https://www.pmusers.com/index.php/Migra ... al_install

3.Upgrading all program to 64bit
- Apache 2.4.38 VC11 (64bit)
- PHP 5.4.16 VC9 (64bit)

4.Upgrading ProcessMaker to 3.2.1
Follow this guide : https://wiki.processmaker.com/3.2/Upgra ... ocessMaker

5.Check program after upgrading. Now I find many errors.
5.1 Not attach file client machine on IE11. But the server is not a problem.
5.2 Some process show ERROR: **Changes to are forbidden. Please contact system administrator for more information.**
5.3 Case label not update follow database.
And some problems that I can fix. Can you help me in 5.1-5.3 ?

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Mon Mar 25, 2019 9:16 pm
by amosbatto
chanatsamon wrote: Sat Mar 23, 2019 8:00 am 5.Check program after upgrading. Now I find many errors.
5.1 Not attach file client machine on IE11. But the server is not a problem.
Are you using a File field in a Dynaform to upload? Does it work with Firefox and Chrome?
chanatsamon wrote:5.2 Some process show ERROR: **Changes to are forbidden. Please contact system administrator for more information.**
You need to edit your execute-query-blacklist.ini file to allow database queries to the ProcessMaker core tables.
See: https://wiki.processmaker.com/3.0/Consu ... ore_Tables

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Mon Mar 25, 2019 9:17 pm
by amosbatto
chanatsamon wrote: Sat Mar 23, 2019 8:00 am 5.3 Case label not update follow database.
Can you better explain this? I don't understand.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Fri Mar 29, 2019 6:15 am
by chanatsamon
Hi Amos,

I found a problem with Report Table. After upgrading processmaker follow this guide --> https://wiki.processmaker.com/3.2/Upgra ... ocessMaker

I new report table but data 0 record.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Fri Mar 29, 2019 6:16 am
by chanatsamon
a sample

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Fri Mar 29, 2019 9:49 pm
by amosbatto
Delete the report table. Then, recreate it with a new name. That usually works for me.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Sun Mar 31, 2019 10:38 pm
by chanatsamon
Hi Amos,
Thank You. I increase the column size, report table it working normally.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Sun Mar 31, 2019 10:41 pm
by chanatsamon
amosbatto wrote: Mon Mar 25, 2019 9:16 pm
chanatsamon wrote: Sat Mar 23, 2019 8:00 am 5.Check program after upgrading. Now I find many errors.
5.1 Not attach file client machine on IE11. But the server is not a problem.
Are you using a File field in a Dynaform to upload? Does it work with Firefox and Chrome?

Yes, It work good with Firefox and Chrome.
But it not work with IE11.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Sun Mar 31, 2019 10:47 pm
by chanatsamon
amosbatto wrote: Mon Mar 25, 2019 9:16 pm
chanatsamon wrote: Sat Mar 23, 2019 8:00 am 5.Check program after upgrading. Now I find many errors.
5.1 Not attach file client machine on IE11. But the server is not a problem.
Are you using a File field in a Dynaform to upload? Does it work with Firefox and Chrome?
Yes, It work good with Firefox and Chrome.
But it not work with IE11.

Ps. Sorry for having to repeat, I still use the web poorly.

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Sun Mar 31, 2019 10:56 pm
by chanatsamon
5.2 Some process show ERROR: **Changes to are forbidden. Please contact system administrator for more information.**
5.3 Case label not update follow database.

These problems have been resolved.
I Import the workspace database(s) from manual install upgrading 3.2.1 to manual install 3.2.1

Re: Migrating from 3.0.1.7 to 3.2.1 version

Posted: Tue Apr 02, 2019 1:49 am
by amosbatto
chanatsamon wrote: Sun Mar 31, 2019 10:47 pm
amosbatto wrote: Mon Mar 25, 2019 9:16 pm
chanatsamon wrote: Sat Mar 23, 2019 8:00 am 5.1 Not attach file client machine on IE11. But the server is not a problem.
Are you using a File field in a Dynaform to upload? Does it work with Firefox and Chrome?
Yes, It work good with Firefox and Chrome.
But it not work with IE11.
Please file a bug report about the problem in http://bugs.processmaker.com and post a link to your bug report here.
Are you using a File field or a MultipleFile field?