Ask questions about installing and configuring ProcessMaker 3

Moderators: ArturoRobles, ArturoRobles

I have moved to a new server, once I wanted to import extraRest api plugin its showing an error:
Code: Select all
You don't have permission to access /sysworkflow/en/neoclassic/setup/pluginsImportFile on this server.
I think its folder permission issue, but I'm not sure which folder should I change its permission.

User: admin
Processmaker version 3.2community
Server: Ubuntu 16.04
php 5.6
I haven't seen that error message before.
Try making your workflow/engine/plugins directory writable.
In Linux:
chmod 755 workflow/engine/plugins
and make sure that the owner is "apache" in CentOS/Red Hat or "www-data" in Debian/Ubuntu.

If that isn't the problem, which version of the extraRest plugin are you using?
I tried to change the permission of the plugins folder even I gave it 777 but it didn't work.
From the previous server it was setup extrarest plugin and active, and once I moved processmaker/shared to a new server it's not visible, the old files are in the plugins folder "/opt/processmaker/workflow/engine/plugins/extraRest",
I tried to remove them but still the same issue.

Let's back to the installation steps, I have installed a fresh processmaker 3.2-community which its the same version on the old server, then restored the backup database, removed the new shared folder and used the old one. Changed all permissions:
Code: Select all
sudo chmod -R 770 shared 
sudo chown -R www-data:www-data /opt/processmaker

did I missed anything?
or it's server configuration?
I found it!! finally!
It was security reason from modsecurity, I have turned off some security rules :

Code: Select all
#       SecDataDir /var/cache/modsecurity
#       IncludeOptional /etc/modsecurity/*.conf
#       IncludeOptional "/usr/share/modsecurity-crs/*.conf
#       IncludeOptional "/usr/share/modsecurity-crs/rules/*.conf
#SecRuleEngine on
#ServerTokens Full
Then I could upload the file extraRest 1.11.
then enabled the security rules and everything is working correctly.

Thank you!
REST API Question

I am currently looking at developing a portlet for[…]

Everybody wants to be famous, but nobody wants to […]

Hi, I attached a sample config file, Please check […]

Error clicking on Participated

Hi, I attached a sample config file, Please check […]