Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By Siriporn
#822991
I see . If I want to upgrade from version 3.0.1.7 to version 3.2.1
I have to upgrade php 5.4 to 5.5 .
could you advise me. How to upgrade php 5.4 to 5.5
thank you very much.
User avatar
By ziadeh
#822993
Processmaker 3.2 you need php 5.6, to upgrade your php follow these steps:

For Ubuntu :
Code: Select all
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install apache2 mysql-server php5.6 php5.6-mbstring php5.6-mcrypt php5.6-mysql php5.6-xml php5.6-gd php5.6-ldap php5.6-curl php5.6-cli php5.6-soap
After that you need to enable the new version of the php
Code: Select all
sudo a2dismod php5.4
sudo a2enmod php5.6
sudo service apache2 restart

Step 2:
Code: Select all
sudo nano /etc/php/5.6/apache2/php.ini
Search for the following lines and edit them using the following configurations:
file_uploads = On
short_open_tag = On
memory_limit = 512M
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
display_errors = Off
post_max_size = 24M
upload_max_filesize = 24M

It is also recommended to set the date.timezone to a your time zone as shown below:
date.timezone = Asia/Istanbul
Then
Code: Select all
sudo service apache2 restart
User avatar
By amosbatto
#823018
Are you using a manual install of ProcessMaker in Windows?
I recommend just upgrading to version 3.2.1, so you don't have change your version of PHP.

If you want to upgrade, then see:
https://www.pmusers.com/index.php/Upgra ... in_Windows

If you have a Bitnami installation, then you will need to do a new manual installation of a recent version of ProcessMaker and then transfer the database and files over to the manual installation. See:
https://www.pmusers.com/index.php/Migra ... al_install

There are number of bugs, that you may want to fix in the source code, if you are going to use recent versions of the Community Edition. See:
https://www.pmusers.com/index.php/Bugs_ ... _upgrading
By chanatsamon
#823020
Hi Amos,

I want upgrade Processmaker 3.0.1.7 to 3.2.1.
But I can't upgrade PHP 5.4 to 5.6 for windows.
Can you suggest a way to upgrade PHP before upgrading Processmaker?
User avatar
By amosbatto
#823039
chanatsamon wrote: I want upgrade Processmaker 3.0.1.7 to 3.2.1.
But I can't upgrade PHP 5.4 to 5.6 for windows.
Can you suggest a way to upgrade PHP before upgrading Processmaker?
If you have a manual install in Windows and want to upgrade from PHP 5.4 to PHP 5.6, then see these instructions:
https://www.pmusers.com/index.php/Upgra ... in_Windows

If you have a Bitnami installation, then you will need to do a new manual installation of a recent version of ProcessMaker and then transfer the database and files over to the manual installation. See:
https://www.pmusers.com/index.php/Migra ... al_install
By chanatsamon
#823072
Hi Amos,

I choose to do item 2.
https://www.pmusers.com/index.php/Migra ... al_install

By trying 2 types.
1. I have version 3.0.1.7 by install from ProcessMaker-3.0.1.7-community-Setup.exe and have version 3.2.1 by Bitnami install
MySql = ฺBackup database no problem.
Processmaker = not working.

2. I manually installed version 3.2.1
I follow the steps listed below to prepare the environment before installing ProcessMaker already done.
https://wiki.processmaker.com/3.0/Stack_210

And install ProcessMaker 3.2.1.
I followed each step till step 4 using this wikia.
https://wiki.processmaker.com/3.0/Windo ... stallation

Now I try to install it on my personal computer. Before installing at the server again.
Which method is better?
By TedShelton
#823079
I am trying to test Windows Server 2012 Backup option. I am backing up on a network share. While creating the backup schedule it gave me an error "The user name being used for accessing the remote share folder is not recognising by the local computer"

$(aRows[i-1]).find("input[type=checkbox]&q[…]

When the web entry form appears, is the name of th[…]

If the case doesn't exist in the APPLICATION table[…]

pass json array into grid

Oops, I forgot to increment the counter. It should[…]