Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

#822299
Hi All,

I am running Processamaker application with MySQL version 5.5. My DB dump size is almost 40 GB. I uninstall version 5.5 and installed 5.6 in the server which is Redhat 7.5. Later restore the dump file and this was also successful.

But when I point my Proccermaker to this new version (MySQL 5.6), I can authenticate successfully but my inbox is not loading. I am getting error..... Wrapped: It is not possible to execute the query. Please contact with system administrator.

Any one have idea about that. I need this urgently.

Thanks for your time.
#822306
If you edit your env.ini file and add the following line:
Code: Select all
debug=1
Then, you should be able to see the error message from MySQL.

If you copied the mysql.user table from MySQL 5.5 to MySQL 5.6, then you are going to need to run this command from the terminal:
mysql_upgrade --force -uroot -p
This will upgrade the mysql.user table so it works correctly in MySQL 5.6.

If you didn't copy the mysql.user table over to MySQL 5.6, then you are going to have to manually create the user for each workspace.
Open your file /opt/processmaker/shared/sites/{workspace}/db.php to get the host, database name, username and password for each workspace.

Then, login to MySQL as the "root" user:
mysql -u root -p
Then, issue the following command for each workspace:
grant all on DATABASE.* to 'USER'@'HOST' identified by 'PASSWORD' with grant option;

For example, if you see the following in your db.php:
Code: Select all
<?php
// Processmaker configuration
  define ('DB_ADAPTER',     'mysql' );
  define ('DB_HOST',        'localhost' );
  define ('DB_NAME',        'wf_workflow330' );
  define ('DB_USER',        'wf_5c05d14cf006c' );
  define ('DB_PASS',        'z!4B_HPW13-etqr' );
  define ('DB_RBAC_HOST',   'localhost' );
  define ('DB_RBAC_NAME',   'wf_workflow330' );
  define ('DB_RBAC_USER',   'wf_5c05d14cf006c' );
  define ('DB_RBAC_PASS',   'z!4B_HPW13-etqr' );
  define ('DB_REPORT_HOST', 'localhost' );
  define ('DB_REPORT_NAME', 'wf_workflow330' );
  define ('DB_REPORT_USER', 'wf_5c05d14cf006c' );
  define ('DB_REPORT_PASS', 'z!4B_HPW13-etqr' );
Then the grant command in MySQL would be:
grant all on wf_workflow330.* to 'wf_5c05d14cf006c'@'localhost' identified by 'z!4B_HPW13-etqr' with grant option;

Remember that you have to do this for each of your workspaces. If you haven't created any additional workspaces, then you will probably only have the default "workflow" workspace whose database is named "wf_workflow".

This might help you:
https://www.pmusers.com/index.php/Upgra ... in_Windows

sorry it didn't get attach first time mysql-erro[…]

Hi guys, Im using process maker 3.3.6-1 community […]

We are using the SAML plugin (see screenshot). Do[…]

Hi, I'm having some issues with the Android app. I[…]