Ask questions about installing and configuring ProcessMaker 3

Moderators: ArturoRobles, ArturoRobles

By PornesianParapio
Hi all.

Can anyone enlighten me how to connect the database? I already tried to configure it so many times but the result is unsuccessful.

This is the message I've got

Thank you
Add description
Untitled.png (27.26 KiB) Viewed 1315 times
Last edited by PornesianParapio on Fri Dec 28, 2018 3:13 am, edited 1 time in total.
User avatar
By amosbatto
First verify that the username and password in MySQL are correct from the command line of your ProcessMaker server. Open a terminal (and go to the directory where Mysql is installed if using Windows) and enter the following command:

Replace the parts in italics. For example:
mysql -h -u jdoe [email protected] my_database

If you aren't able to login, then you might have a priveleges problem. Login as your "root" user in mysql and then use the GRANT command to set the password for the user and set that the user can login on the machine
grant all on DATABASE.* to 'USER'@'ADDRESS' identified by 'PASSWORD' with grant option;

Replace the parts in italics. For example:
grant all on my_database.* to 'jdoe'@'' identified by '[email protected]' with grant option;

If it still doesn't work, then verify that you don't have a firewall that is blocking port 3306. It is a good idea to turn off any firewall when testing. You can use netstat -tln in Linux or netstat -tn in Windows to verify if your server is using port 3306 and MySQL is listening.

Here is what I see on my Linux machine:
Code: Select all
# netstat -tln
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0*               LISTEN     
tcp        0      0    *               LISTEN     
tcp        0      0 *               LISTEN 
You can check your my.cnf file for the port being used by MySQL.
REST API Question

I am currently looking at developing a portlet for[…]

Everybody wants to be famous, but nobody wants to […]

Hi, I attached a sample config file, Please check […]

Error clicking on Participated

Hi, I attached a sample config file, Please check […]