Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By isolice
#822093
System:
Ubuntu 16.04
MySQL 5.7.24
PHP Version 5.6.39
Apache 2.4
------------------------------

Hi I've tried to install processmaker 3.3.0 community edition at least 15 times, every time I get the same result (as attached)
1) the designer does not load correctly
2) if I try to create and save a DynaForm I get "An error occurred while retrieving the access token"

I've spent 3 days searching for similar problems, does anyone have any ideas?

Regards,
Marco
Attachments
processmaker2.png
processmaker2.png (40.04 KiB) Viewed 945 times
processmaker1.png
processmaker1.png (50.48 KiB) Viewed 945 times
By isolice
#822094
Okay after many, many, MANY hours....

I found the solution to my problem, as I was using FPM & FCGI

I needed this line in my vhost config:
Code: Select all
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
I hope this will help someone!
User avatar
By amosbatto
#822102
Thanks for the tip. I never would have thought of that.
User avatar
By ziadeh
#822581
After upgrade from Processmaker 3.2 to 3.3, the designer won't load. Please see the attached image.
Attachments
processmaker-update-3-3-.jpg
processmaker-update-3-3-.jpg (41.47 KiB) Viewed 824 times
processmaker-update-3-3.jpg
processmaker-update-3-3.jpg (51.69 KiB) Viewed 826 times
User avatar
By ziadeh
#822583
I executed these commands and its fixed it:

cd /opt/processmaker
./processmaker migrate-new-cases-lists
./processmaker database-generate-self-service-by-value
User avatar
By amosbatto
#822607
Glad that you figured it out. I never would have thought of trying that.

Hi Amos, Thank you for your kind attention. It is[…]

You can refer to the answer: https://forum.process[…]

Switch from Apache2 to Nginx

Hi, We used Processmaker 3.3.6. Processmaker Swit[…]

error when I restart my server

Thanks for you help Amos. Regarding your question[…]