Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By springhigh
#817660
Moving to Nginx is going to be a bit of a learning curve for our client systems, on pm Enterprise.
We sometimes host multi PM Corporate systems on a single dedicated server, so just wondering if PM can give bit of guidance on Virtual hosting for Nginx etc.
User avatar
By amosbatto
#817663
ajcosta wrote: Wed Nov 07, 2018 2:05 pm Will Apache 2.4.x not be supported in community version 3.3 with Centos 7 and PHP 7.1.x?

https://wiki.processmaker.com/3.3/Supported_Stacks
Apache 2.4.X is supported by PM 3.3 Community. In theory Apache 2.2.X should still work, but it has not been tested. The big change with PM 3.2.3 and later is that it has code that isn't compatible with PHP 5.5, so only PHP 5.6 and 7.X will work.
User avatar
By amosbatto
#817664
springhigh wrote: Wed Nov 07, 2018 3:55 pm Moving to Nginx is going to be a bit of a learning curve for our client systems, on pm Enterprise.
We sometimes host multi PM Corporate systems on a single dedicated server, so just wondering if PM can give bit of guidance on Virtual hosting for Nginx etc.
I haven't tried using multiple server blocks with Nginx. The PM sysops guys have probably figured out how to do this stuff, but they don't post on this forum. Here is a tutorial that explains the basic idea of how to do it:
https://www.keycdn.com/support/nginx-virtual-host
If you get it working, feel free to post instructions on the pmusers.com wiki to help others.
User avatar
By amosbatto
#817720
programerboy wrote: Sat Nov 10, 2018 1:22 pm Hi,

Is it possible to update php5.6 to php7.1 in Processmaker Bitnami Installer?
How can I do it?

Thanks
Unfortunately, we don't have any way to upgrade Bitnami installations. You may be able to upgrade PHP to a newer version, but we don't have a way to upgrade the PM source code in Bitnami.

If you want ProcessMaker to be upgradeable, you have to do a manual installation.
User avatar
By amosbatto
#817762
Marquart wrote: Tue Nov 13, 2018 11:45 am Is there documentation on how to do the installation manually so it's upgradeable later on?
See: https://wiki.processmaker.com/3.2/sys_administration
If the instructions in the wiki involve downloading a .tar.gz file, then it is a manual installation.
For example:
https://wiki.processmaker.com/3.3/Stack_225
https://wiki.processmaker.com/3.3/Stack_N225
If the instructions on the wiki mention Bitnami, then is NOT a manual installation.
Subprocesso

Olá, alguém pode me ajudar na utiliz[…]

I am trying to make file upload field mandatory u[…]

Multiple Uploader in Grids

Are you trying to show all the uploaded files in[…]

Thanks!