Ask questions about installing and configuring ProcessMaker 3

Moderator: amosbatto

By cosyxu
#815347
Hi Amo,

I have read some of the topics here about timezone issues.

Recently, I have upgraded from PM 3.1.X to PM 3.2.2, however, the timezone didn't change to my local time("Australia/Melbourne").

All I knew is to go to

1) In "php.ini", add
Code: Select all
 date.timezone = "Australia/Melbourne"
2) In processmaker/shared/sites/my_workflow/env.ini, add
Code: Select all
time_zone = "Australia/Melbourne"
But still, my ProcessMaker didn't change to this time zone, it still remains in UTC.

Any ideas? Please also find the attached screenshot.

Thanks,

Yuan
Attachments
2018-07-25_16-35-48.png
2018-07-25_16-35-48.png (23.48 KiB) Viewed 2732 times
By cosyxu
#815353
Hi Amo,

Yes, I have restarted Apache many times. :cry:

And I have set up this as my local timezone as well(please refer to the screenshot).

Regards,
Yuan
Attachments
2018-07-27_12-07-35.png
2018-07-27_12-07-35.png (16.59 KiB) Viewed 2720 times
#815356
It looks like Laravel in PM 3.2.2 is overwriting the timezone. What you need to do is edit the file processmaker/config/app.php
and add the line:
Code: Select all
    'timezone' => 'Australia/Melbourne',
So now the file will look something like this:
Code: Select all
<?php

use Illuminate\Cache\CacheServiceProvider;
use Illuminate\Filesystem\FilesystemServiceProvider;
use Illuminate\View\ViewServiceProvider;

return [
    'name' => env('APP_NAME', 'ProcessMaker'),
    'env' => env('APP_ENV', 'production'),
    'debug' => env('APP_DEBUG', false),
    'log' => env('APP_LOG', 'single'),
    'log_level' => env('APP_LOG_LEVEL', 'debug'),
    'cache_lifetime' => env('APP_CACHE_LIFETIME', 60),
    'timezone' => 'Australia/Melbourne',

    'providers' => [
        FilesystemServiceProvider::class,
        CacheServiceProvider::class,
        ViewServiceProvider::class,
    ],

    'aliases' => [
    ],

];
By cosyxu
#815357
Hi Amo,

Thank you so much, timezone issue has been fixed.

Now the default timezone has been changed from UTC to my local timezone.

By the way, any ideas why the filter for email logs not working? (sort descending or ascending) Please refer to the screenshot.

Many thanks,

Yuan
#816173
The developers insist that the time zone with Laravel should be UTC. Does anyone see any problems in their installation of ProcessMaker when the default time zone is set to UTC? Are than any problems when the default time zone is not UTC?

We need feedback from people using ProcessMaker to know if this is a problem. If you find problems, please post screenshots.
By cosyxu
#816181
amosbatto wrote: Wed Sep 19, 2018 10:09 pm The developers insist that the time zone with Laravel should be UTC. Does anyone see any problems in their installation of ProcessMaker when the default time zone is set to UTC? Are than any problems when the default time zone is not UTC?

We need feedback from people using ProcessMaker to know if this is a problem. If you find problems, please post screenshots.
Hi Amo,

As I have been mentioned earlier after I upgrade to PM3.2.2, the timezone remains to be "UTC" even if I make the correct changes, and this cause that all our case and email logs show UTC time, not local time, which really confuse our users.

After following your solution to change in the Laravel, then the timezone shows my local timezone, and all the emails and logs show the correct time. And so far, I haven't found any issue regarding this change.

Please see the attached screen for before and after the change.

Thanks,
Yuan
Attachments
timezone 2.png
timezone 2.png (23.48 KiB) Viewed 2589 times
timezone 2.png
timezone 2.png (23.74 KiB) Viewed 2589 times
#816256
Hello,

I have the same issue.
I will configure the workaround in the app.php
I use a three stage system, so I have a development system, a system-test system and a production system.
The development system and the system-test is up to date with version 3.2.2
I will test the workaround on my development system.

But a question is, could it be possible, that the issue can be fixed by using the configuration for multiple time zones?
But this I can't test beacaus it is an enterprise feature. I use the community edition.

Kind regards Timo
#822192
Skipper, I just tried in PM 3.3.0 Enterprise and I don't see the problem when I go to Admin > Logs > Email. It appears to only be an issue with the Community Edition that doesn't have time zone adjustment.
#823824
Hello,
I've PM Community Edition 3.3.0 and I've the Timezone issue too. All the date times in PM are now in UTC, and not in the 'Europe/Paris' like set in the env.ini and in the php.ini files.
I found today that the root cause is the Default timezone setting from Laravel in LoadConfiguration.php file where it is set by default to UTC (and not using the php.ini setting by default).
I found that it should be defined in the /config/app.php file and that after setting like you advised then all my date times are going to be in the correct timezone. Otherwise it was kept in the UTC.
Is it currently fixed in the 3.3.x versions?
Thank you,
Regards
Tomolimo
#823838
tomolimo wrote: Sat Apr 06, 2019 11:04 am Hello,
I've PM Community Edition 3.3.0 and I've the Timezone issue too. All the date times in PM are now in UTC, and not in the 'Europe/Paris' like set in the env.ini and in the php.ini files.
I found today that the root cause is the Default timezone setting from Laravel in LoadConfiguration.php file where it is set by default to UTC (and not using the php.ini setting by default).
I found that it should be defined in the /config/app.php file and that after setting like you advised then all my date times are going to be in the correct timezone. Otherwise it was kept in the UTC.
Is it currently fixed in the 3.3.x versions?
Thank you,
Regards
Tomolimo

Fixed here: https://github.com/tomolimo/processmake ... 8ac1c7eb8e

Regards,
Tomolimo
#824099
Thank you very much for your reply. :D
solved problem.
tomolimo wrote: Mon Apr 08, 2019 2:58 am
tomolimo wrote: Sat Apr 06, 2019 11:04 am Hello,
I've PM Community Edition 3.3.0 and I've the Timezone issue too. All the date times in PM are now in UTC, and not in the 'Europe/Paris' like set in the env.ini and in the php.ini files.
I found today that the root cause is the Default timezone setting from Laravel in LoadConfiguration.php file where it is set by default to UTC (and not using the php.ini setting by default).
I found that it should be defined in the /config/app.php file and that after setting like you advised then all my date times are going to be in the correct timezone. Otherwise it was kept in the UTC.
Is it currently fixed in the 3.3.x versions?
Thank you,
Regards
Tomolimo

Fixed here: https://github.com/tomolimo/processmake ... 8ac1c7eb8e

Regards,
Tomolimo
#825331
haniayer wrote: Tue Jul 09, 2019 10:37 am Dealing with the same problem. Finally find the solution. Thanks!
Hello,
What solution did you applied?
Thank you,
regards,
Tomolimo

Thanks for your reply, Press F12 in your web bro[…]

I created a new process to make it easier to look […]

Genial!!! gracias. :D

This is resolved. I took a punt on Amos' suggesti[…]