Discussion and questions around ProcessMaker Licensing

Moderator: amosbatto

#784212
Hi!

In my job the company has a ProcessMaker with Enterprice plugins for version 1.0 installed, since a few years ago. My boss instructed me to update PM to the last one version.
I was planned to start with a migration from 1st to 2nd version and afterwards from 2nd version to the 2.8 version. At the end with a migration from 2.8 version to 3.0. I supusse that We need to buy every plugin of the Enterprice version one by one. This for us would be a bad way because We will buy not only the last plugins.

The questions are:

* The best way to update is step by step from version 1 to 2, afterwards from 2 - 2.8 and afterwards from 2.8 to 3 (the lastest version)?
* In order to have every version running. We need to buy every Enterprice plugins of every version?.
* I suppose that We have the core modified because We have duplicates of directories: engine and gulliver. What file is used to configure directories of "engine" and "gulliver".

I don't know if this is the best way to migrate PM.

Best regards
Suggest box not filtering

Thank you so much for your reply. I had the same t[…]

thanks for info

Dear Amosbatto, I managed to connect rest api via[…]

This is a very nice blog to watch out for and we p[…]